The default bug view has changed. See this FAQ.

Crash on startup [@ nsTextFragment::CharAt(int) ] or [@ kernelbase.dll@0x179b ]

RESOLVED FIXED

Status

()

Core
General
--
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Anywho, Unassigned)

Tracking

({crash})

Trunk
x86_64
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:6.0a1) Gecko/20110506 Firefox/6.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:6.0a1) Gecko/20110506 Firefox/6.0a1

This crash happens at startup when using "Net Usage Item" v1.2.310 and v1.2.314. It also happens when using "Imgur Uploader" v1.0.3. Both add-ons previously worked in FF6.0a1 on and before the Nightly 2011-05-04 version.

Reproducible: Always

Steps to Reproduce:
1.  Start FF6.0.a1 with either of these two addons enabled.
2.
3.

Actual Results:  
Crash reporter comes up asking for details.

Expected Results:  
FF6.0a1 should have started.

Running Windows 7-Pro-SP1, 64bit.  Because this has only just started happening, I thought I should report it...  I hope that is OK.
Component: General → General
Depends on: 612532
Keywords: crash
OS: Windows NT → Windows 7
Product: Firefox → Core
QA Contact: general → general
Hardware: Other → x86_64
Version: unspecified → Trunk
(Reporter)

Comment 1

6 years ago
Just adding that "Imgur Uploader 1.0.3" is working when "Net Usage Item" is disabled.  So it appears to be a knock-on effect.

Comment 2

6 years ago
I think these are related. Happen on latest nightly (2011-05-06) on startup when usage item is installed. (I have to remove it by renaming the {guid}.xpi in my profile)

They have a different signature though.
https://crash-stats.mozilla.com/report/index/bp-49b59b49-2230-4a9c-95c0-bdd542110506
https://crash-stats.mozilla.com/report/index/bp-81f1df4e-ece2-4d47-81a7-24db02110506
https://crash-stats.mozilla.com/report/index/bp-f201749d-14b4-4e30-bcee-f02c82110506
(Reporter)

Comment 3

6 years ago
FF6.0a1 - 2011-05-07 has fixed the problem I had with the "Net Usage Item" add-on for me.  "Imgur Uploader 1.0.3" is also fine.  Firefox now starts up without crashing.

Updated

6 years ago
Summary: Crash on startup (nsTextFragment::CharAt(int) is the cause) → Crash on startup [@ nsTextFragment::CharAt(int) ] or [@ kernelbase.dll@0x179b ]

Updated

6 years ago
No longer depends on: 612532

Comment 4

6 years ago
https://crash-stats.mozilla.com/report/list?signature=nsTextFragment%3A%3ACharAt%28int%29 has 2011050600 show up as the highest build ID with crashes, which would confirm what comment #3 is saying and be a good sign. 

Looking at checkins that affect the stack frames in there, it looks to me like bug 655025 fixed this.

Robert Longson, can you confirm that?

Comment 5

6 years ago
Based on the stack trace, the patch in bug 655025 did fix this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Depends on: 655025
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Crash Signature: [@ nsTextFragment::CharAt(int) ] [@ kernelbase.dll@0x179b ]
You need to log in before you can comment on or make changes to this bug.