All users were logged out of Bugzilla on October 13th, 2018

image transformation proxy images(gif,jpeg,png) not displayed

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
18 years ago
3 years ago

People

(Reporter: tstiers-public, Unassigned)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i686; en-US; 0.7) Gecko/20010112
BuildID:    2001011213

I have a proxy that downsizes images - to greyscale, size/resolution, and even
the MIME type (to gif, jpeg, png).
When I use this proxy with Mozilla, the images do not appear, replaced instead
with text or the alt tag.

Reproducible: Always
Steps to Reproduce:
1.set proxy  216.96.160.235 port 2345, account tas/hello
2.go to large jpeg image,
http://216.96.160.235/qa/qa-static/jpeg_large.jpg
3.

Actual Results:  Image does not show up, just url in the screen.

Expected Results:  I expect a transformed image to appear.

Does mozilla freak on an image size change? I change the
MIME type, but not the extension necessarily!!

All other graphical browsers I have tried run fine with the
proxy above (from netscape to iPAQ IE to Pixo microbrowser).

Also,

Proxy-connection: keep-alive
is not present - should it be?

Thanks

Comment 1

18 years ago
Probably a duplicate of bug 38488.
Assignee: pnunn → neeti
Component: ImageLib → Networking
QA Contact: tpreston → tever

Comment 2

18 years ago
Linux 2001011508.

I don't believe this is a dupe of <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=38488">38488</a> because
adding the following to prefs.js doesn't help:

user_pref("network.http.proxy.keep-alive", false);

I'm afraid I can't add anything more useful because of my lack of knowledge.

Marking as NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

18 years ago
Blocks: 61691
Target Milestone: --- → mozilla1.2

Comment 3

18 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc

Updated

16 years ago
Target Milestone: mozilla1.2alpha → Future

Comment 4

16 years ago
moving neeti's futured bugs for triaging.
Assignee: neeti → new-network-bugs
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.