Status

()

--
enhancement
VERIFIED FIXED
18 years ago
8 years ago

People

(Reporter: afranke, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This may or may not be useful. If it's not useful, feel free to mark wontfix.

Two alternative definitions for an "assertion" keyword: 
a) For bugs where an assertion is mentioned. (it's a substring of long_desc)
b) For bugs that contain reproduceable steps to trigger an assertion.

Alternative a) would avoid the need to query the long_desc for the "assertion"
substring, see the URL field of this bug. There are currently 323 open bugs with
this substring.
If a developer sees an assertion, she can then efficiently query for existing
bugs where this assertion is also mentioned. It would be easy to set up an
"assertion finder" query form that is specialized on this kind of queries:
It would be a text field where you enter a substring of the assertion message
(and maybe there would be a checkbox to exclude resolved bugs from the query),
and when you press return, a query would be submitted for all bugs that contain
the assertion keyword and the given text in one of the comments.

Of course, it's possible to set up such a tool even without the keyword, but
then it would have to search all the comments of all bugs, and that's slow.
(Reporter)

Comment 1

18 years ago
Check out http://www.ags.uni-sb.de/~afranke/mozilla/assertionfinder.html with
the example query "window != null" to get a feeling for the performance.
(Assignee)

Comment 2

18 years ago
I think this would be a good addition.  I'll try to get it set up soon.  This is
another place where they need to be looked at and evaluated individually for the
keyword since not all of them are cases where an assertion is the reported
problem.   I think it might be overkill to add it wherever the string assertion
shows up.  I'll see if I can get a group together to take on this task as soon
as I've got the keyword created.
Status: NEW → ASSIGNED

Comment 3

18 years ago
sounds like a good keyword.

Updated

18 years ago
QA Contact: lchiang → timeless
(Reporter)

Comment 4

17 years ago
Proposed description:
A bug that triggers an assertion.
(Assignee)

Comment 5

17 years ago
Fixed. 
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
vrfy fixed
Status: RESOLVED → VERIFIED
Component: Bugzilla: Keywords & Components → Administration
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.