When printing a page containing a very long fieldset block that should span several pages, only the first page of it is printed

RESOLVED DUPLICATE of bug 471015

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 471015
7 years ago
6 years ago

People

(Reporter: OMA, Unassigned)

Tracking

2.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

When printing a page that contains a very tall fieldset block that needs several pages to be fully printed, only one page of it gets printed. I know there are several bugs filed about one-page printing in Firefox, but in version 4 this only seems to happen with fieldsets.

Using Firefox 4.0.1

Reproducible: Always

Steps to Reproduce:
1. Create a simple page with a long fieldset that should span several pages (sorry, I don't know of an example available in the Internet)
2. Print it!


Actual Results:  
Only one page of the fieldset gets printed. If there are other elements outside the fieldset, those will be printed in separate pages, but the fieldset is still being cut, taking only one of the pages printed.

Expected Results:  
The fieldset spans the pages it needs to show all of its lines, not just one

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 1

7 years ago
An example is:
http://www.classic-clocks.co.uk/options.asp?clockID=1&Requestor=gallery

It has a form with fieldsets that is longer than one page. In PRINT and PRINT PREVIEW only the first page of the form is shown.

Bug 258397 claims that this problem is fixed in Firefox 4, but I just installed 4.0.1 and the problem is still there.

Updated

7 years ago
Component: General → Printing: Output
Product: Firefox → Core
QA Contact: general → printing
Version: 4.0 Branch → 2.0 Branch
(Reporter)

Comment 2

7 years ago
Thanks for your comment and the link to a live example! That's exactly what happens. As you can see in the above link, when printing:

1. The first page only has the title and a few paragraphs of text, then almost all of the page is blank because the fieldset doesn't fit in the first page, so it gets moved to the second page. It shouldn't do that! It should be printed just below the text, as shown in the browser!

2. The fieldset, even starting in a fresh new page, still doesn't fit in a single page, but its rendering doesn't continue in the third page. It just gets cut!

3. In the third page we get the remaining elements of the page (a div block with more text), but not the remaining content inside the fieldset, which just gets cut in the second page.

I'm sorry, but despite seeming efforts to fix it, Firefox printing is still broken, and it's been broken since, what, 2003? (that's when these "single page printing" issues were first reported, AFAIK). I hope some resources can be allocated to fix these printing issues once and for all.
(In reply to comment #1)
> Bug 258397 claims that this problem is fixed in Firefox 4, but I just
> installed 4.0.1 and the problem is still there.

That bug doesn't mention fieldsets at all (instead, it's about "overflow:hidden", which is indeed fixed for printing in Firefox 4).

I'm not sure why you picked that bug out for mentioning here.

(In reply to comment #0)
> Only one page of the fieldset gets printed. If there are other elements
> outside the fieldset, those will be printed in separate pages, but the
> fieldset is still being cut, taking only one of the pages printed.

This is Bug 471015.  Marking as duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 471015
(Reporter)

Comment 4

7 years ago
I see, thank you! I couldn't find that 471015 bug, so I filed this.

And it seems that bug was filed in December, 2008
so that's still 2 years and a half without correcting this bug! :-(
(Reporter)

Comment 5

7 years ago
The example URL in bug 471015 is not so good, though, because the fieldset fits in one page.
(In reply to comment #5)
> The example URL in bug 471015 is not so good, though, because the fieldset
> fits in one page.

External URLs aren't to be trusted, because their contents change/disappear over time. :)

There are several testcases attached to the bug which reproduce the bug just fine, though.
You need to log in before you can comment on or make changes to this bug.