If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Implement a temporary file mechanism for XHR2 response blob

RESOLVED DUPLICATE of bug 1202006

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1202006
7 years ago
a day ago

People

(Reporter: emk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
See bug 649133 comment #16.
Do we want Blobs here or disk-backed Files?  We have existing infrastructure for in-memory blobs ...
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Do we want Blobs here or disk-backed Files?  We have existing infrastructure
> for in-memory blobs ...
My current patch already uses in-memory blobs as a fallback. This bug is about an improvement of the fallback.
Disk-backed blobs are required to handle huge files such as video media or ISO image.
http://lists.w3.org/Archives/Public/public-webapps/2010OctDec/0334.html
If we don't implement disk-backed blobs, we don't have to implement blobs in the first place. In-memory blobs have little advantage over arraybuffers (especially when bug 648997 is fixed).
Yup. I think we should do something better here. Even cooler would be if we for large memory-backed blobs streamed them to disk and morphed the blob into a disk-backed one. Possibly after some timeout allowing the blob to go away completely instead.

Comment 4

a day ago
baku, wasn't this fixed back in Firefox 52 with bug 1202006 ?
Flags: needinfo?(amarchesini)
Yes. This is fixed.
Status: NEW → RESOLVED
Last Resolved: a day ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1202006
You need to log in before you can comment on or make changes to this bug.