Last Comment Bug 655872 - Cleanup get_inner_gdk_window
: Cleanup get_inner_gdk_window
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: Trunk
: All Linux
: -- minor (vote)
: mozilla6
Assigned To: Hiroyuki Ikezoe (:hiro)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-09 16:15 PDT by Hiroyuki Ikezoe (:hiro)
Modified: 2011-05-12 03:38 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
A patch (1.94 KB, patch)
2011-05-09 16:15 PDT, Hiroyuki Ikezoe (:hiro)
karlt: review+
Details | Diff | Review

Description Hiroyuki Ikezoe (:hiro) 2011-05-09 16:15:48 PDT
Created attachment 531188 [details] [diff] [review]
A patch

get_inner_gdk_window is little bit inefficient because there is a g_list_nth in a loop and g_list_nth traverses the list.
Comment 1 Mounir Lamouri (:mounir) 2011-05-12 03:38:33 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/25597fcfaffe

Note You need to log in before you can comment on or make changes to this bug.