Last Comment Bug 655932 - black flicker when opening or enlarging arrow panels
: black flicker when opening or enlarging arrow panels
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla6
Assigned To: Karl Tomlinson (back Dec 13 :karlt)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-09 21:06 PDT by Karl Tomlinson (back Dec 13 :karlt)
Modified: 2011-07-21 02:24 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
shape before drawing (2.11 KB, patch)
2011-05-09 21:13 PDT, Karl Tomlinson (back Dec 13 :karlt)
ventnor.bugzilla: review+
Details | Diff | Splinter Review

Description Karl Tomlinson (back Dec 13 :karlt) 2011-05-09 21:06:29 PDT
When opening the bookmarks or identity arrow panels for the first time, or enlarging the bookmarks panel with "Show all the bookmarks folders", there is a black flicker where the panel should be transparent.
Comment 1 Karl Tomlinson (back Dec 13 :karlt) 2011-05-09 21:13:24 PDT
Created attachment 531239 [details] [diff] [review]
shape before drawing

I wrote this when looking at bug 635897, but this is not just for broken window managers.

We shouldn't be painting black into the window while it is still visible (or has just become visible but hasn't yet been shaped), and this may actually speed up painting the visible portion, because I assume the behavior from painting a region that is still shaped out is undefined.
Comment 2 Michael Ventnor 2011-05-09 23:33:18 PDT
I thought we cleared the window to black to clear out the malloc gunk from our buffer. With this patch, what happens when you have a panel background with alpha 0.6 (or something thats not low enough to trigger bring cleared by Xshape)?
Comment 3 Karl Tomlinson (back Dec 13 :karlt) 2011-05-10 02:34:17 PDT
This patch shouldn't change what's drawn to our buffer.  ctx here is drawing to the window.
The patch doesn't change what happens when 0 < alpha < 1 (though treating 1/255 as alpha == 1 does seem a bad idea and gives black edges).
Comment 4 Karl Tomlinson (back Dec 13 :karlt) 2011-05-12 22:01:33 PDT
http://hg.mozilla.org/mozilla-central/rev/ebc9a7e1fb12
Comment 5 George Carstoiu 2011-07-21 02:24:01 PDT
Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20100101 Firefox/6.0 - beta 2
Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110719 Firefox/8.0a1

I can no longer see any black flickers when enlarging the bookmarks panel.

Setting status to Verified Fixed.

Note You need to log in before you can comment on or make changes to this bug.