Last Comment Bug 655970 - Web page is partially displayed in Firefox 4
: Web page is partially displayed in Firefox 4
Status: RESOLVED WORKSFORME
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 4.0 Branch
: All All
: -- normal (vote)
: Firefox 6
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.video-giochi.org/giochi_on...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-10 02:53 PDT by Francesco Lodolo [:flod]
Modified: 2011-05-26 00:08 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Cleaned up code (78.53 KB, text/html)
2011-05-10 02:53 PDT, Francesco Lodolo [:flod]
no flags Details

Description Francesco Lodolo [:flod] 2011-05-10 02:53:38 PDT
Created attachment 531279 [details]
Cleaned up code

The problem was reported on the Italian support forum and it started with Firefox 4 (Firefox 3.6 displays the page correctly). What's strange is that the code displayed using View source is complete.

The code of this page is a complete mess (table, fonts, etc.), so I tried at least to clean it up from the ads (see attached file)
Comment 1 Marco Bonardo [::mak] 2011-05-10 07:30:19 PDT
Setting html5.parser.enable to false solves the problem.
2 noticeable things on this page:
- it doesn't have a doctype
- the <b> tag on the last entry is not correctly closed

cc-ing Sivonen for the html5 parser.
Comment 2 Marco Bonardo [::mak] 2011-05-10 07:32:23 PDT
I meant "on the last visible entry", that is this one
<font face="verdana" size="3"><b>MONSTERS GONE WILD - Una 'mostruosa' gara di ballo</a><br>
Comment 3 Marco Bonardo [::mak] 2011-05-10 07:35:34 PDT
the page is fully visible in Chrome, Opera and IE (latest versions)
Comment 4 Marco Bonardo [::mak] 2011-05-10 08:17:23 PDT
Correctly closing tags solves the problem (both adding missing closing tags, and reordering out of order closing tags).
It's mostly matter of figuring out if this is the expected behavior or if we should fallback to some compatibility support.
Comment 5 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2011-05-26 00:08:58 PDT
As far as I can tell, the site looks the same in Firefox, in Chrome, in IE6 and in Opera Ragnarök.

Note You need to log in before you can comment on or make changes to this bug.