need nsIHistoryObserver interface and underlying implementation

VERIFIED FIXED in mozilla0.8

Status

defect
--
major
VERIFIED FIXED
19 years ago
3 months ago

People

(Reporter: jud, Assigned: radha)

Tracking

({embed})

Trunk
mozilla0.8
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Reporter

Description

19 years ago
http://www.mozilla.org/projects/embedding/apiReviewNotes.html#nsIHistoryObserver 
points to what we're after to provide more functional history info for 
embeddors.

Here's the latest info:

[1/4/01]

Too complicated to have embedding app impl the current session history 
interfaces. 
See nsIWebNavigation for other notes. 
We have to maintain loaded state internally. It's not enoughthat the embedding 
app maintain a list of URLs which they LoadURI() on when the user jumps around 
in the history list. 
It's not clear whether or not we should be index (number) based or cookie 
(history entry interface) based. 
Maybe the embedding app tells us *when* to trim, thus makingthe index option 
more attractive.
Reporter

Comment 1

19 years ago
nominating 0.8
Blocks: 64833
Severity: normal → major
Keywords: embed, mozilla0.8
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.8
I have attached a initial patch for the implementation. I'm seeking input (from
appripriate people) for certain parts of the patch. This patch has not been
built on linux yet.
Reporter

Comment 5

19 years ago
I don't see the nsWebBRowser.cpp changes in there to enable session history 
observer registration from nsIWebBrowser.
oops! forgot to attach nsWebBrowser.cpp diffs in the previous patch id 24170. 
The latest one 24242 has it. Thanks jud for pointing it out.
Reporter

Comment 8

19 years ago
nice! r=valeski

Comment 9

19 years ago
In nsISHistory.idl:

    * Add a new Entry to the History List
-       * @param aEntry - The entry to add
-       * @param aPersist - If true this specifies that the entry should persist
-       * in the list.  If false, this means that when new entries are added
-       * this element will not appear in the session history list.
+        * @param aEntry - The entry to add
+        * @param aPersist - If true this specifies that the entry should
persist
+        * in the list.  If false, this means that when new entries are added
+        * this element will not appear in the session history list.
    */

radha, would you mind fixing this so the *s lines up (since you're touching
those lines anyway)?

Will there only ever be one history listener or should we support multiple
listeners? The comments could be more clear on this, as could the method names
(setSHistoryListener or something).
sr=rpotts (thro' email) and this got checked in yesterday. 

jag: for your question, each browser window or embedding window will have its 
own instance of SH. SH is not a service. so, it is enough if each instance have 
one listener. 
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
*** Bug 28615 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Keywords: mozilla0.8

Comment 12

18 years ago
Moving API bug ownership to David Epstein.
QA Contact: mdunn → depstein

Comment 13

18 years ago
Correction: Changing QA contact for the Embed API bugs to David Epstein.

Comment 14

18 years ago
Interface is now called nsISHistoryListener. Idl file found in lxr.mozilla.org 
Used in winEmbed for history notifications (in AddWebBrowserListener()).
Status: RESOLVED → VERIFIED

Updated

18 years ago
No longer blocks: 64833

Updated

3 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.