Last Comment Bug 656114 - Clicking is broken in position:fixed elements in Fennec with MOZ_ENABLE_FIXED_POSITION_LAYERS enabled
: Clicking is broken in position:fixed elements in Fennec with MOZ_ENABLE_FIXED...
Status: VERIFIED FIXED
: mobile, regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: All All
: -- major (vote)
: Firefox 8
Assigned To: Oleg Romashin (:romaxa)
:
:
Mentors:
http://www.gog.com/
Depends on: 652240
Blocks: 607417
  Show dependency treegraph
 
Reported: 2011-05-10 13:08 PDT by Cork
Modified: 2014-11-07 10:39 PST (History)
12 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
test case (338 bytes, text/html)
2011-05-10 16:33 PDT, Matt Brubeck (:mbrubeck)
no flags Details
Fix click for fixed layers after zoom (749 bytes, patch)
2011-08-10 13:55 PDT, Oleg Romashin (:romaxa)
ben: review+
Details | Diff | Splinter Review

Description User image Cork 2011-05-10 13:08:31 PDT
With the current nightly i can't focus the password or email field. This worked fine last i tested (back in dec).

Steps to Reproduce:
1. Open the URL
2. Click "Account login" at the top right
3. Try to set focus in the password by tapping the field

Actual Results:
Nothing happens when the field is clicked.

Expected Results:
Focus should be moved to the input field,
Comment 1 User image Matt Brubeck (:mbrubeck) 2011-05-10 16:15:45 PDT
This is likely a regression from bug 607417.  This bug does not appear in Firefox 4, but it does appear on Aurora (Firefox 5) and Nightly (Firefox 6).
Comment 2 User image Matt Brubeck (:mbrubeck) 2011-05-10 16:33:15 PDT
Created attachment 531497 [details]
test case

This affects more than just form fields.  Clicks are not dispatched correctly to position:fixed elements in Fennec.  Steps to reproduce:

1. Open the attached test case in Fennec.
2. Zoom in, then scroll down.
3. Click on "Click me."

Expected results: The link is activated, and navigates to example.com.
Actual results: Nothing happens.
Comment 3 User image Benjamin Stover (:stechz) 2011-05-10 16:36:06 PDT
Another good reason to turn off position: fixed layers for now.
Comment 4 User image Matt Brubeck (:mbrubeck) 2011-05-10 16:57:52 PDT
(In reply to comment #3)
> Another good reason to turn off position: fixed layers for now.

Filed bug 656167.
Comment 5 User image Oleg Romashin (:romaxa) 2011-05-10 19:06:15 PDT
It looks like events are not properly redirected to content with fixed position...
it is possible to enter/activate input fields if your page is scrolled to (0, y) position, and if X!=0, then events are redirected somewhere else..., also page automatically centered if you click on input field (X!=0) and in order to switch to password field you need to scroll page back to X=0 position and then click on password field..
do we have any magic in events coordinates translation code when they are sent from Parent to Child? scroll offsets? 

also interesting that different Y- position does not break this behavior.
Comment 6 User image Benjamin Stover (:stechz) 2011-05-10 19:12:02 PDT
We'd like to get this behavior into platform. See bug 652240.
Comment 7 User image Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-05-13 13:53:43 PDT
seems to have broken in 4/9, 4/8 works.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.2a1pre) gecko/20110409 Firefox/4.2a1pre Fennec/4.1a1pre
Mac OS X 10.6.7
Comment 8 User image Mark Finkle (:mfinkle) (use needinfo?) 2011-07-21 07:58:01 PDT
fixed by bug 656167, but we hope to turn position:fixed back on, so leaving this open.
Comment 9 User image Andreea Pod 2011-08-09 08:48:38 PDT
I also tried to reproduce this following the steps from Comment 2 and it's not happening. Should we mark this as WORKSFORME?

Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110809 Firefox/8.0a1 Fennec/8.0a1
Device: LG Optimus 2X (Android 2.2)
Comment 10 User image Kevin Brosnan [:kbrosnan] 2011-08-09 11:43:07 PDT
This works for me as well using a current Nightly. Cork reopen if you can repro.
Comment 11 User image Tatiana Meshkova (:tatiana) 2011-08-09 13:40:02 PDT
(In reply to Kevin Brosnan [:kbrosnan] from comment #10)
> This works for me as well using a current Nightly. Cork reopen if you can
> repro.

see #comment8
Comment 12 User image Oleg Romashin (:romaxa) 2011-08-10 13:55:36 PDT
Created attachment 552207 [details] [diff] [review]
Fix click for fixed layers after zoom

Ok, so link clicking broken after zoom, but works again after little scroll, which make it clear that problem is in missing updateCSSViewport after zoom animation finished...
Comment 13 User image Doug Turner (:dougt) 2011-08-11 11:34:22 PDT
oleg, land on m-i?
Comment 15 User image Matt Brubeck (:mbrubeck) 2011-08-12 08:11:26 PDT
https://hg.mozilla.org/mozilla-central/rev/0324f71c6757
Comment 16 User image Catalin Suciu [:csuciu] 2011-08-31 06:09:21 PDT
I wasn't able to reproduce this issue on Mozilla/5.0 (Android;Linux armv7l;rv:7.0)Gecko/20110830 Firefox/9.0a1 Fennec/7.0
Device: HTC Desire
OS: Android 2.2

Note You need to log in before you can comment on or make changes to this bug.