Closed Bug 656156 Opened 11 years ago Closed 11 years ago

Compatibility check flag should be for each extension

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 527861

People

(Reporter: will.pittenger1+mozbugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

I noticed that when I have extensions like Addon Compatibility Reporter installed, it disables the compatibility check flag.  That is fine when you are testing.  However, for most users, that doesn't sound like a good idea to me.  They still need to be alerted while installing an addon listed as incompatible.  The difference should be that the application would offer to install the extension anyway.

Reproducible: Always

Steps to Reproduce:
1.Disable compatibility check.
2.Attempt to install an extension that is marked as incompatible (like something really old).
3.The application won't warn you that the extension is incompatible during the install.  There will be a note in about:addons for that extension, but that is it.

Actual Results:  
The application won't inform users about a compatibility problem during install without simply refusing the extension.  If the compatibility check is disabled, the user won't know there is a potential problem without checking about:addons.

Expected Results:  
With the compatibility check "disabled," the application should still check the compatibility check and inform the user.  It should then offer the user the choice between not installing the addon and installing it anyway.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 527861
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.