Last Comment Bug 656205 - Remove unused browser migration code (MacIE, iCab, OmniWeb, Dogbert a.k.a. Netscape, and Camino)
: Remove unused browser migration code (MacIE, iCab, OmniWeb, Dogbert a.k.a. Ne...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 6
Assigned To: Makoto Kato [:m_kato]
:
Mentors:
: 578270 (view as bug list)
Depends on:
Blocks: 236305 578270 608947
  Show dependency treegraph
 
Reported: 2011-05-10 22:16 PDT by Makoto Kato [:m_kato]
Modified: 2011-07-23 10:45 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (100.97 KB, patch)
2011-05-16 01:16 PDT, Makoto Kato [:m_kato]
mak77: review+
Details | Diff | Review

Description Makoto Kato [:m_kato] 2011-05-10 22:16:29 PDT
Final version of MacIE was released as 2003 and there is no Intel version release.

Also, target platform of Firefox trunk is Intel version and OSX 10.5 or later.  I think that MacIE migratory doesn't need.
Comment 1 Justin Dolske [:Dolske] 2011-05-10 22:27:27 PDT
Indeed, most of the migration code is crufty, old, and no longer useful. Removing MacIE would be a good start, and if you're motivated to purge some of the others that would be great too!
Comment 2 Makoto Kato [:m_kato] 2011-05-11 18:12:55 PDT
(In reply to comment #1)
> Indeed, most of the migration code is crufty, old, and no longer useful.
> Removing MacIE would be a good start, and if you're motivated to purge some
> of the others that would be great too!

At least, no one needs old Phoenix migration.  I will file a new bug for it.
Comment 3 Marco Bonardo [::mak] 2011-05-11 18:28:08 PDT
I guess ICab OmniWeb and Dogbert can go as well.
I'm available to review if browser peers are fine with that.
Comment 4 Makoto Kato [:m_kato] 2011-05-12 18:43:18 PDT
We should remove iCab, OmniWeb and Camino migration because this implementation is template only and commented in XUL.  So, it doesn't work.

http://mxr.mozilla.org/mozilla-central/source/browser/components/migration/content/migration.xul?mark=76-80#76
Comment 5 Makoto Kato [:m_kato] 2011-05-16 01:16:00 PDT
Created attachment 532577 [details] [diff] [review]
fix
Comment 6 Marco Bonardo [::mak] 2011-05-16 18:28:06 PDT
Comment on attachment 532577 [details] [diff] [review]
fix

Review of attachment 532577 [details] [diff] [review]:
-----------------------------------------------------------------

I've done some search in mxr and looks like you removed all the relations, nice!

r=me with the below addressed or answered:

::: browser/components/migration/src/nsOperaProfileMigrator.h
@@ +45,5 @@
>  #include "nsISupportsArray.h"
>  #include "nsStringAPI.h"
>  #include "nsTArray.h"
>  #include "nsINavHistoryService.h"
> +#include "nsIStringBundle.h"

why this isolated change in the Opera migrator?
Comment 7 Makoto Kato [:m_kato] 2011-05-16 18:53:32 PDT
(In reply to comment #6)
> Comment on attachment 532577 [details] [diff] [review] [review]
> fix
> 
> Review of attachment 532577 [details] [diff] [review] [review]:
> -----------------------------------------------------------------
> 
> I've done some search in mxr and looks like you removed all the relations,
> nice!
> 
> r=me with the below addressed or answered:
> 
> ::: browser/components/migration/src/nsOperaProfileMigrator.h
> @@ +45,5 @@
> >  #include "nsISupportsArray.h"
> >  #include "nsStringAPI.h"
> >  #include "nsTArray.h"
> >  #include "nsINavHistoryService.h"
> > +#include "nsIStringBundle.h"
> 
> why this isolated change in the Opera migrator?

If nothing, it will causes build break (http://tinderbox.mozilla.org/showlog.cgi?log=Try/1305523324.1305528492.5285.gz) when compiling nsModule.cpp.
Comment 8 Marco Bonardo [::mak] 2011-05-17 02:20:13 PDT
Ah, I see.
OperaProfileMigrator.cpp includes nsIStringBundle.h before its own header
62 #include "nsIStringBundle.h"
63 #include "nsISupportsPrimitives.h"
64 #include "nsNetUtil.h"
65 #include "nsOperaProfileMigrator.h"
Instead in nsModule.cpp we include only the header and nsIStringBundle.h was included by a previous migrator header that you removed.
The trybuild was a really good idea! :)
Comment 9 Makoto Kato [:m_kato] 2011-05-17 23:34:02 PDT
http://hg.mozilla.org/mozilla-central/rev/676006c214ad
Comment 10 Dão Gottwald [:dao] 2011-05-18 03:23:00 PDT
*** Bug 578270 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.