Closed Bug 656286 Opened 9 years ago Closed 7 years ago

virus scan e-mails from staging are confusing

Categories

(Release Engineering :: Release Automation: Other, defect, P5)

x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bhearsum, Assigned: massimo)

Details

(Whiteboard: [release][automation])

Attachments

(3 files)

I did part of staging release today and a AV vendor e-mail went to release@mozilla.com. This is good, but the subject is confusing. In staging/preproduction it would be helpful to tag them the same way we do other release mails: with [staging] or [preprod-release].
Priority: -- → P5
Whiteboard: [release][automation]
No longer blocks: hg-automation
Mass move of bugs to Release Automation component.
Component: Release Engineering → Release Engineering: Automation (Release Automation)
No longer blocks: hg-automation
Attachment #669926 - Flags: review?(bhearsum)
Comment on attachment 669926 [details] [diff] [review]
patch for bug 656286

This looks OK, but let's make sure the behaviour in consistent with similar options in createReleaseMessage by factoring out to getSubject() and getMessageTag():
https://github.com/mozilla/buildbotcustom/blob/master/process/release.py#L164
https://github.com/mozilla/buildbotcustom/blob/master/process/release.py#L205
Attachment #669926 - Flags: review?(bhearsum) → review-
added getMessageTag()
Attachment #672540 - Flags: review?(bhearsum)
Comment on attachment 672540 [details] [diff] [review]
added getMessageTag()

Review of attachment 672540 [details] [diff] [review]:
-----------------------------------------------------------------

::: process/release.py
@@ +271,5 @@
> +    def getMessageTag():
> +        return releaseConfig.get('messagePrefix', '[release] ')
> +
> +    def getSubject():
> +        subject = getMessageTag() + '%(productName)s %(version)s release'

We should actually drop this, since it's not used everywhere, and put this assignment create in createReleaseAVVendorsMessage. Looks fine otherwise.
Comment on attachment 672540 [details] [diff] [review]
added getMessageTag()

Need the below addressed, removing review.

::: process/release.py
@@ +271,5 @@
> +    def getMessageTag():
> +        return releaseConfig.get('messagePrefix', '[release] ')
> +
> +    def getSubject():
> +        subject = getMessageTag() + '%(productName)s %(version)s release'

We should actually drop this, since it's not used everywhere, and put this assignment create in createReleaseAVVendorsMessage. Looks fine otherwise.
Attachment #672540 - Flags: review?(bhearsum)
Attached patch patch for 656286Splinter Review
resending patch. In the last upload I have sent the wrong one. My fault.
Attachment #673961 - Flags: review?(bhearsum)
Comment on attachment 673961 [details] [diff] [review]
patch for 656286

Review of attachment 673961 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good now, thanks! I landed this on the default branch.
Attachment #673961 - Flags: review?(bhearsum) → review+
Assignee: nobody → mgervasini
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.