Last Comment Bug 656365 - Creating an arguments object shouldn't require a parent, only a callee
: Creating an arguments object shouldn't require a parent, only a callee
Status: RESOLVED FIXED
fixed-in-tracemonkey
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-11 10:37 PDT by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2011-05-23 14:17 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (4.56 KB, patch)
2011-05-11 14:38 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
luke: review+
Details | Diff | Splinter Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-11 10:37:17 PDT
The one is redundant with the other, so we only need callee to get the job done.
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-11 14:38:30 PDT
Created attachment 531755 [details] [diff] [review]
Patch

Try's testing this now, and I expect it'll be golden.

http://tbpl.mozilla.org/?tree=Try&rev=5308e1f0b72a
Comment 2 Nicholas Nethercote [:njn] 2011-05-11 16:20:04 PDT
Golden?  You must be running a new version of TBPL :P
Comment 3 Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-11 16:25:19 PDT
Har har.

Turns out "it" is not golden, but I highly doubt it's this patch.  I'm bisecting through the few changes it might be (all but the last five or so have previously tryservered green) in that push to figure out which is at issue.  That series of patches minus the one here still crashes, and one five or so back doesn't, so it's an intermediate patch with a bug, should be easy enough to spot.  It doesn't matter much anyway, tho, because I need so many of the other changes to land first, and it's not really worth the trouble to move the patch further up the queue to push it sooner.
Comment 4 Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-11 16:46:02 PDT
Yeah, not a problem with this patch, just a wider-flung change than possible in bug 655907.
Comment 5 Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-18 14:20:48 PDT
http://hg.mozilla.org/tracemonkey/rev/993f0935af4c
Comment 6 Chris Leary [:cdleary] (not checking bugmail) 2011-05-23 14:17:29 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/993f0935af4c

Note You need to log in before you can comment on or make changes to this bug.