Crash [@ nsDocShell::SetDocCurrentStateObj ]

RESOLVED DUPLICATE of bug 656354

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 656354
7 years ago
7 years ago

People

(Reporter: tchung, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

7 years ago
Hit this crash while using F1 to share a webpage via facebook wall.   

Environment: 
- Nightly Mac build: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110511 Firefox/6.0a1
- Addon: F1 by Mozilla Labs  0.8.3

Repro:
1) install F1 0.8.3 on nightly build
2) setup F1 to share with facebook
3) find a page, click F1, and share via Facebook wall
4) on first click, notice it throws an notification error saying to "Try again"
5) click try again, and crashes.

Expected:
- no crash, post to F1

ActuaL:
- crash 

https://crash-stats.mozilla.com/report/index/bp-46d274ac-0580-4302-bff5-922bb2110511

Stack Trace:
Frame 	Module 	Signature [Expand] 	Source
0 	XUL 	nsDocShell::SetDocCurrentStateObj 	docshell/base/nsDocShell.cpp:7750
1 	XUL 	nsDocShell::InternalLoad 	docshell/base/nsDocShell.cpp:8408
2 	XUL 	nsDocShell::LoadURI 	docshell/base/nsDocShell.cpp:1424
3 	XUL 	nsDocShell::LoadURI 	docshell/base/nsDocShell.cpp:3729
4 	XUL 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_x86_64_unix.cpp:195
5 	XUL 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:3144
6 	XUL 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1610
7 	XUL 	js::Interpret 	js/src/jscntxtinlines.h:277
8 	XUL 	js::RunScript 	js/src/jsinterp.cpp:603
9 	XUL 	js::Invoke 	js/src/jsinterp.cpp:684
10 	XUL 	js::ExternalInvoke 	js/src/jsinterp.cpp:806
11 	XUL 	JS_CallFunctionValue 	js/src/jsapi.cpp:5079
12 	XUL 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1903
13 	XUL 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:9129
14 	XUL 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:9474
15 	XUL 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:424
16 	XUL 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:520
17 	XUL 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:618
18 	XUL 	NS_ProcessPendingEvents_P 	obj-firefox/x86_64/xpcom/build/nsThreadUtils.cpp:200
19 	XUL 	nsBaseAppShell::NativeEventCallback 	widget/src/xpwidgets/nsBaseAppShell.cpp:130
20 	XUL 	nsAppShell::ProcessGeckoEvents 	widget/src/cocoa/nsAppShell.mm:422
21 	CoreFoundation 	__CFRunLoopDoSources0 	
22 	CoreFoundation 	__CFRunLoopRun 	
23 	CoreFoundation 	CFRunLoopRunSpecific 	
24 	HIToolbox 	HIToolbox@0x2e939 	
25 	HIToolbox 	HIToolbox@0x2e69c 	
26 	HIToolbox 	HIToolbox@0x2e5f7 	
27 	AppKit 	_DPSNextEvent 	
28 	CoreFoundation 	__CFRunLoopModeEqual 	
29 	CoreFoundation 	CFEqual 	
30 	CoreFoundation 	__CFBasicHashStandardCallback 	
31 	CoreFoundation 	___CFBasicHashFindBucket1 	
32 	CoreFoundation 	__CFBasicHashStandardCallback 	
33 	CoreFoundation 	___CFBasicHashFindBucket1 	
34 	libSystem.B.dylib 	libSystem.B.dylib@0x66b3 	
35 	CoreFoundation 	_CFRetain 	
36 	CoreFoundation 	__CFBasicHashAddValue 	
37 	CoreFoundation 	CFBasicHashAddValue 	
38 	CoreFoundation 	CFBasicHashGetCountOfKey 	
39 	CoreFoundation 	CFRunLoopAddObserver 	
40 	AppKit 	_DPSConvertMaskToEventTypeList 	
41 	AppKit 	-[NSApplication setWindowsNeedUpdate:] 	
42 	AppKit 	-[NSEvent window] 	
43 	AppKit 	stub helpers 	
44 	AppKit 	-[NSApplication sendEvent:] 	
45 	AppKit 	-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] 	
46 	libSystem.B.dylib 	libSystem.B.dylib@0xa2d8 	
47 	libSystem.B.dylib 	libSystem.B.dylib@0x823b 	
48 	CoreFoundation 	CFBasicHashRemoveValue 	
49 	libobjc.A.dylib 	libobjc.A.dylib@0x771a 	
50 	CoreFoundation 	-[NSObject dealloc] 	
51 	HIToolbox 	HIToolbox@0x554c 	
52 	AppKit 	-[NSEvent dealloc] 	
53 	libSystem.B.dylib 	libSystem.B.dylib@0x66c7 	
54 	CoreFoundation 	_CFAutoreleasePoolPop 	
55 	AppKit 	stub helpers 	
56 	libSystem.B.dylib 	libSystem.B.dylib@0x66c7 	
57 	Foundation 	Foundation@0x2eed 	
58 	CoreFoundation 	_CFAutoreleasePoolPush 	
59 	libSystem.B.dylib 	libSystem.B.dylib@0x66c7 	
60 	AppKit 	stub helpers 	
61 	AppKit 	-[NSApplication run] 	
62 	XUL 	nsAppShell::Run 	widget/src/cocoa/nsAppShell.mm:769
63 	XUL 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:224
64 	XUL 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3698
65 	firefox-bin 	main 	browser/app/nsBrowserApp.cpp:159
66 	firefox-bin 	firefox-bin@0x953
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 656354
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsDocShell::SetDocCurrentStateObj ]
You need to log in before you can comment on or make changes to this bug.