Broken OpenGL rendering - black rectangles / bars

VERIFIED DUPLICATE of bug 705002

Status

()

--
major
VERIFIED DUPLICATE of bug 705002
8 years ago
a year ago

People

(Reporter: Virtual, Unassigned)

Tracking

({nightly-community})

Trunk
x86_64
Windows 7
nightly-community
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:6.0a1) Gecko/20110511 Firefox/6.0a1
Build Identifier: 

Just set to true layers.prefer-opengl in about:config
Same as layers.prefer-d3d9 because of bug #605808

Reproducible: Always
Blocks: 546508
Depends on: 649685
Version: unspecified → Trunk

Comment 2

7 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:7.0a1) Gecko/20110621 Firefox/7.0a1

Can you please post the information from about:support - the Graphics section, and also what drivers you are using for your video card?

Thanks!
Sure thing.

Graphics
Adapter Description - NVIDIA GeForce 8600 GT
Vendor ID - 10deDevice ID0402
Adapter RAM - 256
Adapter Drivers - nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version - 8.17.12.7550
Driver Date - 6-15-2011
Direct2D Enabled - true
DirectWrite Enabled - true (6.1.7601.17563)
ClearType Parameters - ClearType parameters not found
WebGL Renderer - NVIDIA Corporation -- GeForce 8600 GT/PCI/SSE2 -- 3.3.0GPU
Accelerated Windows - 1/1 Direct3D 10

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:7.0a1) Gecko/20110621 Firefox/7.0a1
on Windows 7 64bit with SP1 + latest updates
GPU drivers are also newest 275.50 beta

Comment 4

7 years ago
Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110627 Firefox/7.0a1

From what I understand here https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#NVIDIA_cards your video card should be supported. Still, try disabling hardware acceleration and see whether you can still reproduce the problem.
HW Acceleration is enabled, because if it won't, how OpenGL rendering will works...?
It's simply bug with OpengGL.
Just do what I said on the start and you will also see this...

Updated

7 years ago
tracking-firefox7: ? → ---
Created attachment 590668 [details]
Screenshot2

Bumping because it still happen on Firefox 12.0a1pre
Can someone look into this, because it's still marked as unconfirmed

Attaching also a new screenshot

Just set to "true" a "layers.prefer-opengl" option in "about:config" too see this bug
Duping forward to bug 705002. OGL Layers on Windows is not an actively supported supported configuration. I would love to see it working, but we're already actively supporting both d3d9 and d3d10 layers on windows.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 705002
No longer depends on: 701277
No longer blocks: 546508, 605808
Status: RESOLVED → VERIFIED
No longer depends on: 649685
You need to log in before you can comment on or make changes to this bug.