Fallback to sRGB monitor profile doesn't work as documented

RESOLVED WORKSFORME
(NeedInfo from)

Status

()

defect
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: dion, Unassigned, NeedInfo)

Tracking

4.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20110430 Firefox/4.0.1 Iceweasel/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20110430 Firefox/4.0.1 Iceweasel/4.0.1

I've created two JPEG images (created with sRGB color space):
http://dion.org.ua/uploads/2011/05/20110427_131508_00_srgb_icc.jpg
http://dion.org.ua/uploads/2011/05/20110427_131508_00_srgb_noicc.jpg

As I said, both of them are sRGB, but first of them contains embedded sRGB profile while second -- don't.

As a result, first image is displayed oversaturated:
http://dion.org.ua/uploads/2011/05/firefox_wrong_colors.jpg

I've created screenshot with same (first) image rendered with different applications:
1. GIMP: supports color profiles
2. Gwenview: has no color management at all.
3. Bibble: it's "source", how image should look. 

The idea is that sRGB profile basically can be just ignored without any visible visual artifacts. So firefox tries to apply something but performs it wrongly.

I think that it's NOT about unsupported ICCv4 profiles, because I can't reproduce it on Windows Vista machine (same Firefox 4). 

gfx.color_management.enabled=2
gfx.color_management.display_profile=""

According to docs, display_profile is:
   A string containing the full path to an ICM profile for output. Default is an empty string in which case the systems global profile is used. If no global profile can be found a default sRGB profile is used. "

I've tried to download srgb.icc file from http://color.org/ and set it as display_profile. This fixes issue on linux and image became correct.

Reproducible: Always

Steps to Reproduce:
1. Open links in Debian's Iceweasel or official Firefox 4 package from mozilla.org on Linux

Actual Results:  
Two images are rendered with different colors (grass)

Expected Results:  
Images should be same

Iceweasel 4.0.1 on Debian: wrong colors
Iceweasel 3.5.19 on Debian: wrong colors
Official Firefox 4.0.1 on Debian: wrong colors
Official Firefox 4.0.1 on Vista: works
Firefox 4.0.1 using Wine: works
OS: Linux → All
Version: unspecified → 4.0 Branch
Dmitry, have you tried this on the latest nightly build?
Hi,

Just tested nightly build with followed user agent:
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110622 Firefox/7.0a1

And it's still affected. So first image (with embedded profile) is rendered incorrectly.
This bug is still present on: Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111003 Firefox/10.0a1
WFM on:
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0

Can you still reproduce this issue?
Flags: needinfo?(dion)
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.