Runtime CPU features detection does not work for pixman in Android

RESOLVED FIXED in Firefox 5

Status

()

Core
Graphics
--
major
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: Siarhei Siamashka, Assigned: Siarhei Siamashka)

Tracking

(Blocks: 1 bug, {mobile, perf, regression})

unspecified
mozilla6
ARM
Android
mobile, perf, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox5- fixed, fennec5+)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20110506 Firefox/4.0.1
Build Identifier: 

NEON optimizations do not work in Android. This causes serious performance problems, especially for the compositing operations involving bilinear scaling.

Reproducible: Always
(Assignee)

Comment 1

6 years ago
Created attachment 532049 [details] [diff] [review]
pixman-neon-fix-for-android.patch

fix
Attachment #532049 - Flags: review?(jmuizelaar)
(Assignee)

Updated

6 years ago
OS: Other → Android
Hardware: Other → ARM
Assignee: nobody → siarhei.siamashka
Blocks: 598736
tracking-fennec: --- → ?
Keywords: mobile, perf
(Assignee)

Updated

6 years ago
Blocks: 656797
Blocks: 640250
Status: UNCONFIRMED → NEW
status-firefox5: --- → affected
tracking-firefox5: --- → ?
Ever confirmed: true
Keywords: regression
tracking-fennec: ? → 6+
Attachment #532049 - Flags: review?(jmuizelaar) → review+
http://hg.mozilla.org/mozilla-central/rev/840a30ab5348
Status: NEW → RESOLVED
tracking-fennec: 6+ → ?
Last Resolved: 6 years ago
Resolution: --- → FIXED
tracking-fennec: ? → 6+

Updated

6 years ago
tracking-firefox5: ? → -
Comment on attachment 532049 [details] [diff] [review]
pixman-neon-fix-for-android.patch

We're pretty sure this is a regression from Fx4 to Fx5 that will result in slower performance since we were not using NEON at all on Android.
Attachment #532049 - Flags: approval-mozilla-beta?

Comment 4

6 years ago
Comment on attachment 532049 [details] [diff] [review]
pixman-neon-fix-for-android.patch

would be nice to have mobile attending these triage sessions.
Attachment #532049 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 5

6 years ago
Comment on attachment 532049 [details] [diff] [review]
pixman-neon-fix-for-android.patch

Please land this change on both Aurora and Beta. (In the future, getting changes in during Aurora will save you this extra step.)
Attachment #532049 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 6

6 years ago
Just to confirm something, is firefox5 mobile going to be released with or without this bug?
Unless it's landed on aurora and beta real soon now, without - but it's approved for beta (i.e. Fx5)!
I can land this in beta next week, if no gets to it first.  (It's already on Aurora now because of the m-c to aurora merge.)
Target Milestone: --- → mozilla6
Oh man we dropped the ball not getting this into bate before beta 3

http://hg.mozilla.org/releases/mozilla-beta/rev/7b250e2b4f57

It's baked on trunk and aurora for a while with no ill effects. It's in beta now, headed to Fx5.
status-firefox5: affected → fixed
tracking-fennec: 6+ → 5+
You need to log in before you can comment on or make changes to this bug.