Last Comment Bug 656873 - When I right-click on a link in a page containing MathML, parts of the page content disappear.
: When I right-click on a link in a page containing MathML, parts of the page c...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: MathML (show other bugs)
: 2.0 Branch
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 605605
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-13 03:21 PDT by Sven
Modified: 2011-05-15 18:11 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
The promised testcase. (773 bytes, application/xhtml+xml)
2011-05-13 03:24 PDT, Sven
no flags Details

Description Sven 2011-05-13 03:21:45 PDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

This only happens at some pages containing MathML with operators such as /, ], ), and a link. Upon clicking on the link (does not matter whether it's a left-click or a right-click), random parts of the page starting from the MathML operator are no longer displayed. 

This happens to me with Firefox 4.0.1 on Linux, but not with Firefox 3.6.16. It happened with FF 4.0.0 on Windows 7, but no longer with FF 4.0.1 on Windows.
 

Reproducible: Always

Steps to Reproduce:
1. Load attached file in browser.
2. Right-click on the link in the second line.
3. Watch everything after the '/' in '0/0' disappear.

Actual Results:  
Part of the page content disappears.

Expected Results:  
Page content should remain visible.

I will add an attachement with a simple testcase.
Comment 1 Sven 2011-05-13 03:24:43 PDT
Created attachment 532159 [details]
The promised testcase.

Use this file to reproduce the bug.
Comment 2 Matthias Versen [:Matti] 2011-05-13 18:09:00 PDT
wfm with Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110511 Firefox/6.0a1 SeaMonkey/2.2a1pre and FF4.0.1
Comment 3 (mostly gone) XtC4UaLL [:xtc4uall] 2011-05-14 04:27:37 PDT
Is your Issue reproducible in Safe-Mode?
https://support.mozilla.com/en-US/kb/Safe+Mode
Comment 4 Alice0775 White 2011-05-14 08:03:04 PDT
This was fixed on Firefox/5.0a2.
Fixed Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fbe53bc0d7f6&tochange=dacd66ab4dc4
Comment 5 Sven 2011-05-15 03:15:47 PDT
@Matti: yes, the bug did not manifest on Windows with FF4.0.1

@XtC4Uall: yes

@Alice0775: thanks, I tested it with 5.0a2 and the bug seems to be gone

@all: thanks for the help
Comment 6 Karl Tomlinson (:karlt) 2011-05-15 18:11:06 PDT
Hoping this might have been fixed by bug 605605.

Note You need to log in before you can comment on or make changes to this bug.