Last Comment Bug 657013 - Remove the old JSON parser
: Remove the old JSON parser
Status: RESOLVED FIXED
fixed-in-tracemonkey
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla6
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
:
Mentors:
: 482895 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-13 13:46 PDT by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2015-10-08 08:50 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (26.58 KB, patch)
2011-05-13 13:46 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
no flags Details | Diff | Splinter Review
Forgot to qref (30.46 KB, patch)
2011-05-13 14:01 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
n.nethercote: review+
Details | Diff | Splinter Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-13 13:46:06 PDT
Created attachment 532338 [details] [diff] [review]
Patch

I think we're past the point now where we might be forced to revert to the old one, at least as concerns Firefox 6.  In the unlikely event that something causes 5 to revert, we can fix such an issue in the new parser in time for 6.
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-13 14:01:10 PDT
Created attachment 532343 [details] [diff] [review]
Forgot to qref
Comment 2 Nicholas Nethercote [:njn] 2011-05-13 22:25:00 PDT
Comment on attachment 532343 [details] [diff] [review]
Forgot to qref

Review of attachment 532343 [details] [diff] [review]:
-----------------------------------------------------------------

Look at all those removed lines!  r=me
Comment 3 Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-18 14:20:13 PDT
http://hg.mozilla.org/tracemonkey/rev/4833e6d0d439
Comment 4 Chris Leary [:cdleary] (not checking bugmail) 2011-05-23 14:18:10 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/4833e6d0d439
Comment 5 André Bargull 2015-10-08 08:50:52 PDT
*** Bug 482895 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.