Create a new Execute menu for Scratchpad

VERIFIED FIXED in Firefox 6

Status

()

Firefox
Developer Tools
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: rc, Assigned: rc)

Tracking

unspecified
Firefox 6
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [scratchpad][fixed-in-devtools][merged-to-mozilla-central])

Attachments

(1 attachment, 3 obsolete attachments)

(Assignee)

Description

6 years ago
Move "Execute, Inspect, Print" from the Edit menu to a new Execute
menu: "Execute", "Inspect value", "Append value as comment".
(Assignee)

Updated

6 years ago
Hardware: ARM → All
(Assignee)

Updated

6 years ago
Assignee: nobody → rcampbell
Status: NEW → ASSIGNED
(Assignee)

Comment 1

6 years ago
this is going to be the third top-level menu beginning with the letter E. Just sayin'.
(Assignee)

Updated

6 years ago
Depends on: 657136
(Assignee)

Comment 2

6 years ago
Created attachment 533402 [details] [diff] [review]
execute menu

execute menu with renames for Execute, Inspect, Print (Run, Inspect, Display).
Attachment #533402 - Flags: review?(mihai.sucan)
(Assignee)

Comment 3

6 years ago
Created attachment 533567 [details] [diff] [review]
execute menu

removed extraneous separator from edit menu
Attachment #533402 - Attachment is obsolete: true
Attachment #533402 - Flags: review?(mihai.sucan)
Attachment #533567 - Flags: review?(mihai.sucan)
(Assignee)

Comment 4

6 years ago
Created attachment 533583 [details] [diff] [review]
execute menu

renamed execute to run and print to display. Updated method names in scratchpad.js and in unittests.
Attachment #533567 - Attachment is obsolete: true
Attachment #533567 - Flags: review?(mihai.sucan)
Attachment #533583 - Flags: review?(mihai.sucan)
Comment on attachment 533583 [details] [diff] [review]
execute menu

Review of attachment 533583 [details] [diff] [review]:
-----------------------------------------------------------------

Patch is fine, just some minor nits. r+!

::: browser/base/content/scratchpad.xul
@@ +246,1 @@
>        <menuitem id="sp-text-execute"

This ID needs to be sp-text-run.

::: browser/base/content/test/browser_scratchpad_ui.js
@@ +37,1 @@
>      "sp-text-inspect": "inspect",

Somehow I forgot sp-text-display when I wrote the test. Please add it.
Attachment #533583 - Flags: review?(mihai.sucan) → review+
(Assignee)

Updated

6 years ago
Blocks: 653108
(Assignee)

Comment 6

6 years ago
Created attachment 533716 [details] [diff] [review]
[in-devtools] execute menu 2

corrected based on feedback.
Attachment #533583 - Attachment is obsolete: true
Attachment #533716 - Flags: review?(sdwilsh)
Comment on attachment 533716 [details] [diff] [review]
[in-devtools] execute menu 2

Review of attachment 533716 [details] [diff] [review]:
-----------------------------------------------------------------

r=sdwilsh
Attachment #533716 - Flags: review?(sdwilsh) → review+
(Assignee)

Updated

6 years ago
Whiteboard: [scratchpad] → [scratchpad][fixed-in-devtools]
(Assignee)

Comment 8

6 years ago
Comment on attachment 533716 [details] [diff] [review]
[in-devtools] execute menu 2

http://hg.mozilla.org/projects/devtools/rev/2a10e886f3d7
Attachment #533716 - Attachment description: execute menu 2 → [in-devtools] execute menu 2

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [scratchpad][fixed-in-devtools] → [scratchpad][fixed-in-devtools][merged-to-mozilla-central]
Target Milestone: --- → Firefox 6

Comment 9

6 years ago
Comment on attachment 533716 [details] [diff] [review]
[in-devtools] execute menu 2

http://hg.mozilla.org/mozilla-central/rev/2a10e886f3d7

Comment 10

6 years ago
Verified fixed on:
Windows 7:
Mozilla/5.0 (Windows NT 6.1; rv:6.0a2) Gecko/20110525 Firefox/6.0a2
Window XP:
Mozilla/5.0 (Windows NT 5.1; rv:6.0a2) Gecko/20110525 Firefox/6.0a2
Mac OS 10.6
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a2) Gecko/20110525 Firefox/6.0a2 
Linux i686:
Mozilla/5.0 (X11; Linux i686; rv:6.0a2) Gecko/20110525 Firefox/6.0a2

*Note: In Scratchpad, under Execute the following options are available: Run, Inspect, Display. Marking this as Verified.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 656544
You need to log in before you can comment on or make changes to this bug.