Closed Bug 657144 Opened 12 years ago Closed 12 years ago

<progress> is mis-rendered when using Equinox engine

Categories

(Core :: Widget: Gtk, defect)

All
Linux
defect
Not set
minor

Tracking

()

RESOLVED WONTFIX

People

(Reporter: paul, Unassigned)

Details

Attachments

(1 file)

Attached image screenshot
Looks like the background box is smaller than the actual progressmeter.
See the screenshot.
Version: 2.0 Branch → Trunk
On my Linux box (non-Ubuntu) it's working fine. I've also tested on another Linux box with Ubuntu and it was working.

Is data:text/html,<progress value=0.5></progress> also mis-rendered?
Could you tell me which version of Ubuntu you are using with which GTK theme.
Hardware: x86 → All
I've tried with the different gtk theme I have on my Ubuntu.
Sounds like this bug happens only with the Equinox themes.

Besides these themes, it's working well.
Summary: <progress> looks weird on Ubuntu → <progress> looks weird with the Equinox GTK themes
It appears only with the Equinox theme (tested with 1.50 which seems to be the last release). This is obviously a bug in the theme: the bar is rendered with a left and top offset. You can see that the bar isn't rendered in the download manager for example.

We have two solutions: either special-casing this theme when drawing the progress bar or not doing anything on our side and file a bug upstream. I would tend to do the later. Karl, what's your opinion?
Component: DOM: Core & HTML → Widget: Gtk
QA Contact: general → gtk
Oh, actually, they know the issue, according to http://gnome-look.org/content/show.php/Equinox+GTK+Engine?content=121881
(it's in "Known bugs" section)
Summary: <progress> looks weird with the Equinox GTK themes → <progress> is mis-rendered when Equinox engine
I wonder why it works fine in GtkProgressBar.  It doesn't seem to do anything too fancy.  http://git.gnome.org/browse/gtk+/tree/gtk/gtkprogressbar.c?h=gtk-2-24#n996
Perhaps the theme is using some other properties from the widget passed to gtk_paint_box.

Is there reason to think the Equinox theme is widely used?
Apparently Equinox is based on the Aurora engine, so Aurora may or may not have the same issue.  I don't know whether or not Aurora is more common.

I'm not keen on special-casing the theme, but if there is a general workaround, such as resizing the widget, then we could do that.  Finding the appropriate workaround involves looking at the Equinox theme engine code, and I don't know whether it's worth the trouble.
(In reply to comment #5)
> Is there reason to think the Equinox theme is widely used?

I do not think it is. It's not even in the official Canonical repository for Ubuntu 10.10 and it's not in my Gentoo's official tree.

> Apparently Equinox is based on the Aurora engine, so Aurora may or may not
> have the same issue.  I don't know whether or not Aurora is more common.

I will check Aurora.

> I'm not keen on special-casing the theme, but if there is a general
> workaround, such as resizing the widget, then we could do that.  Finding the
> appropriate workaround involves looking at the Equinox theme engine code,
> and I don't know whether it's worth the trouble.

I don't want to special case because it's going to be error prone. Though, I've been looking at the code today and I do believe the issue is in there. I think that there is a confusion with the cairo "context". Indeed, the margin you can see in the screenshot is actualy equivalent to the x and y position of the element in the page. I've been able to fix that but something else in the rendering was still not working.
I'm marking the issue minor and I will try to have another look later.
Severity: normal → minor
Summary: <progress> is mis-rendered when Equinox engine → <progress> is mis-rendered when using Equinox engine
If it's obviously a bug in the theme (which probably wasn't tested with non-zero x,y because GtkProgressBar always passes 0,0) then I don't see a good reason to try to fix it in Gecko.
Oh, I hadn't realized that we had definitely decided it was a bug in the theme. Given that, WONTFIX.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
(In reply to comment #4)
> Oh, actually, they know the issue, according to
> http://gnome-look.org/content/show.php/Equinox+GTK+Engine?content=121881
> (it's in "Known bugs" section)

Just to be clear, that section mentions a bug in progress bars in Firebox. It doesn't necessarily mean they understand it's a bug in their code. Perhaps Michael could contact the theme authors and explain the bug to them.
It appears that the guy is a french speaker so I took a few minutes to send him an email. I will try to let you guys know what he replies.
You need to log in before you can comment on or make changes to this bug.