If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Check last link on left frame

RESOLVED DUPLICATE of bug 64488

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 64488
7 years ago
7 years ago

People

(Reporter: igor.feher, Unassigned)

Tracking

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

It will not load an image if viewed online. It will operate properly if loaded locally from HDD.
Here is test case:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>
<head>
<title>XXYY</title>
<script language="JavaScript"> 

function testchange()
{
 document.getElementById('IamCrazyimg').src='IamCrazy\\Wecanfly.jpg';
}
</script>

</head>
<body>
 <form action="IamCrazy.htm" >
  <input type="button"  value="<<" onclick="testchange()" />
 </form>
 <img id="IamCrazyimg" src="IamCrazy\\Wearenotalone.jpg" />
</body>
</html>

Reproducible: Always

Steps to Reproduce:
1.open file offline - it will work
2.open file online, it will show image broken
3.

Actual Results:  
there is no image

Expected Results:  
it works in opera and IE9

You can download images from page slobos.byethost6.com

I hope I did not overlooked something that IE9 and Opera fixed automatically.

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 1

7 years ago
There are two mistakes here:

a) In a URL the slashes should be forward
b) In Javascript an escaped backslash becomes a single one but
   in attribute is two.

   document.getElementById('IamCrazyimg').src='IamCrazy/Wecanfly.jpg';
   <img id="IamCrazyimg" src="IamCrazy/Wearenotalone.jpg" />

Some browsers incorrectly swap '\' to '/'. [But see also bug 652186]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 64488
You need to log in before you can comment on or make changes to this bug.