Last Comment Bug 657251 - Finish off the removal of content_xmldoc.xpt
: Finish off the removal of content_xmldoc.xpt
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: Phil Ringnalda (:philor, back in August)
:
Mentors:
Depends on: 457102
Blocks: 657208
  Show dependency treegraph
 
Reported: 2011-05-15 14:23 PDT by Phil Ringnalda (:philor, back in August)
Modified: 2011-05-28 14:01 PDT (History)
3 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix v.1 (2.11 KB, patch)
2011-05-15 14:23 PDT, Phil Ringnalda (:philor, back in August)
bzbarsky: review+
Details | Diff | Splinter Review

Description Phil Ringnalda (:philor, back in August) 2011-05-15 14:23:09 PDT
Created attachment 532528 [details] [diff] [review]
Fix v.1

Bug 457102 removed all the .idls in content/xml/document/public/, but left the XPIDL_MODULE = content_xmldoc behind, which makes packaging warn about a "package error or possible missing or unnecessary file: bin/components/content_xmldoc.xpt" since we don't create an empty one.

There's some risk to removing the XPIDL_MODULE, since if someone throws a .idl in there sometime later, and sees that it winds up in content.xpt, they need to make the right decision and put an XPIDL_MODULE back in, rather than trying to ship content.xpt (which the updater removes on OS X, because we accidentally shipped one there at one point), but since I don't know how to do khuey's suggestion, get rid of nsIXMLContentSink and thus get rid of the whole public directory, this is the best I can do.
Comment 1 Boris Zbarsky [:bz] 2011-05-25 10:15:58 PDT
Comment on attachment 532528 [details] [diff] [review]
Fix v.1

r=me
Comment 2 Phil Ringnalda (:philor, back in August) 2011-05-28 14:01:32 PDT
http://hg.mozilla.org/mozilla-central/rev/2c7a0ec1fd83

Note You need to log in before you can comment on or make changes to this bug.