Last Comment Bug 657337 - Form input selection arrows are rendered partially off screen after switching from landscape to portrait mode
: Form input selection arrows are rendered partially off screen after switching...
Status: VERIFIED FIXED
:
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: Firefox 6
Assigned To: Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
:
Mentors:
http://aaronmt.com/?p=449
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-16 06:21 PDT by u88484
Modified: 2011-07-14 21:29 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot (50.22 KB, image/png)
2011-05-16 12:08 PDT, u88484
no flags Details
Patch (618 bytes, patch)
2011-05-19 08:52 PDT, Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
mark.finkle: review+
Details | Diff | Review

Description u88484 2011-05-16 06:21:04 PDT
Form input selection arrows are rendered partially off screen after switching from landscape to portrait mode

1) Go to http://aaronmt.com/?p=4492
2) Flip to landscape mode
3) Select one of the input boxes (no need to type)
4) Hit the back button to dismiss the keyboard
5) Flip to portrait mode and notice the arrows are rendered partially off screen
Comment 1 Tony Chung [:tchung] 2011-05-16 09:20:01 PDT
unable to reproduce on a Nexus S, 5/16 nightly build.   Can you report which phone you're using, and also include a screenshot?
Comment 2 u88484 2011-05-16 12:08:29 PDT
Created attachment 532703 [details]
Screenshot

Rooted Evo 4G with cyanogen mod 7.  Try loading the page in landscape mode first.
Comment 3 Aaron Train [:aaronmt] 2011-05-16 12:35:04 PDT
(In reply to comment #1)
> unable to reproduce on a Nexus S, 5/16 nightly build.   Can you report which
> phone you're using, and also include a screenshot?

I can reproduce with Kurt'z suggestion in comment #2 (load the page in landscape, and rotate to portrait after tap in the field)
Comment 4 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-05-18 10:22:47 PDT
I can't reproduce on a nexus one even with the suggestion of #c2. I should do something wrong.
Comment 5 Tony Chung [:tchung] 2011-05-18 10:36:05 PDT
Kurt, are you still able to reproduce on the latest nightly? i filed bug 657836 yesterday which may now affect this bug.
Comment 6 Aaron Train [:aaronmt] 2011-05-18 10:43:03 PDT
I can still reproduce on my N1 Vivien, with 05/18.

Try loading in landscape, tap the comment field, dismiss the keyboard, and then rotate to portrait
Comment 7 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-05-19 04:16:39 PDT
(In reply to comment #6)
> I can still reproduce on my N1 Vivien, with 05/18.
> 
> Try loading in landscape, tap the comment field, dismiss the keyboard, and
> then rotate to portrait

Really I can't. But maybe I'm on the wrong page because I don't have any "comment" field on that page, onyl a search field since the page is "Not Found" for me.
Comment 8 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-05-19 06:00:50 PDT
Also I don't think this bug should block FF6 since the arrows are going to be hidden on Android once bug 636339 will land.
Comment 9 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-19 06:05:26 PDT
(In reply to comment #8)
> Also I don't think this bug should block FF6 since the arrows are going to
> be hidden on Android once bug 636339 will land.

It will certainly be a low priority and it won't block Fx6. The resize/positioning issue in this bug might be impacting other code too. So if we can figure out the cause, it would make our code more robust.

(tracking-fennec != blocking-fennec)
Comment 10 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-05-19 08:52:25 PDT
Created attachment 533660 [details] [diff] [review]
Patch

There is a race between the resizeHandler calls of chrome/content/browser.js and the resize handler of the content popup helper code.
Comment 11 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-19 09:03:25 PDT
Comment on attachment 533660 [details] [diff] [review]
Patch

It's good to know this could happen
Comment 12 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-05-20 03:20:29 PDT
http://hg.mozilla.org/mozilla-central/rev/c43e76fa8647
Comment 13 Anna (Waverley) 2011-05-23 07:24:17 PDT
Due to the fact that form assistant feature was dropped , I will mark this bug as verified fixed.

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110523 Firefox/6.0a1 Fennec/6.0a1

Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:5.0a2) Gecko/20110522 Firefox/5.0a2 Fennec/5.0a2 

Device: HTC Desire Z (Android 2.2)

Note You need to log in before you can comment on or make changes to this bug.