Last Comment Bug 657396 - code coverage builds busted in elfhack
: code coverage builds busted in elfhack
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla6
Assigned To: Mike Hommey [:glandium]
:
:
Mentors:
http://tinderbox.mozilla.org/showlog....
Depends on:
Blocks: 449532
  Show dependency treegraph
 
Reported: 2011-05-16 10:38 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2011-05-17 00:40 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Move LDFLAGS after other flags when building elfhack test case (1.00 KB, patch)
2011-05-16 11:30 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Ted Mielczarek [:ted.mielczarek] 2011-05-16 10:38:09 PDT
These used to break in JS, now they're broken in elfhack, probably fallout from GCC 4.5/PGO:
/tools/gcc-4.5/bin/g++ -fno-rtti -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -Wno-long-long -fprofile-arcs -ftest-coverage -fno-strict-aliasing -std=gnu++0x -pthread -pipe -fexceptions  -DDEBUG -D_DEBUG -DTRACING -g -fPIC -shared -Wl,-z,defs -Wl,-h,test.so -o test.so test.o
===
=== If you get failures below, please file a bug describing the error
=== and your environment (compiler and linker versions), and use
=== --disable-elf-hack until this is fixed.
===
/builds/slave/cen-lnx-codecoverage/build/objdir/build/unix/elfhack/elfhack -b test.so
test.so: Reduced by 3984 bytes
# Fail if the backup file doesn't exist
[ -f "test.so.bak" ]
# Fail if the new library doesn't contain less relocations
[ $(objdump -R test.so.bak | wc -l) -gt $(objdump -R test.so | wc -l) ]
/tools/gcc-4.5/bin/gcc -lpthread -lgcov -static-libgcc   -Wl,-rpath-link,/builds/slave/cen-lnx-codecoverage/build/objdir/dist/bin -Wl,-rpath-link,/usr/local/lib -o dummy dummy.o test.so
dummy.o: In function `global constructors keyed to 65535_0_dummy.c':
/builds/slave/cen-lnx-codecoverage/build/build/unix/elfhack/dummy.c:5: undefined reference to `__gcov_init'
dummy.o:(.data.rel+0x24): undefined reference to `__gcov_merge_add'
collect2: ld returned 1 exit status
NEXT ERROR make[7]: *** [dummy] Error 1
Comment 1 Mike Hommey [:glandium] 2011-05-16 11:22:03 PDT
Can't reproduce locally with the code-coverage mozconfig :-/
Comment 2 Mike Hommey [:glandium] 2011-05-16 11:30:13 PDT
Created attachment 532694 [details] [diff] [review]
Move LDFLAGS after other flags when building elfhack test case

I managed to reproduce, and fix.
Comment 3 Mike Hommey [:glandium] 2011-05-17 00:40:04 PDT
http://hg.mozilla.org/mozilla-central/rev/14bbc2fa43a7

Note You need to log in before you can comment on or make changes to this bug.