Incorrect rendering when font-variant is specified inside of element with text-decoration [FONT]

VERIFIED DUPLICATE of bug 181336

Status

()

defect
P2
normal
VERIFIED DUPLICATE of bug 181336
21 years ago
17 years ago

People

(Reporter: waldemar, Assigned: attinasi)

Tracking

({css1, testcase})

Trunk
Future
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CSS1-5.4.3][CSS1-5.2.4])

Attachments

(3 attachments)

Small-caps style inherits style information incorrectly.  Take a look at the
first instance of the small-caps word "Integer" on this page.  According to the
CSS style, it should be all red.  Instead, the first letter is red and the
remaining ones are blue.  I did not set a first-letter property anywhere in the
style sheet.

I placed a screenshot of what this looks like on <http://www.mozilla.org/js/temp/
integer.gif>.

    Waldemar

PS.  I am running Mac System 8.6.
Summary: Incorrect style inheritance
Posted image Screen shot
Deleted <http://www.mozilla.org/js/temp/integer.gif>.  Please see the attachment
above instead.
OS: Mac System 8.5 → All
Hardware: Macintosh → All
This problem effects the Windows 98 M7 build as well.
Assignee: peterl → kipp
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: M8
I changed the style sheet of the page given in the URL (http://www.mozilla.org/
js/language/js20/lexer-semantics.html), and it no longer is a good test case for
this bug.  Use the small attachment provided by kberk instead.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
The problem was that the current color was being reset when the text decoration,
in this case an underline, was being drawn so that the next chunk of text
rendered in the smallcaps font was drawn in the wrong color. The bug had nothing
to do with style inheritance.
Status: RESOLVED → VERIFIED
Using 7/13 Apprunner, verified fixed. 'Integer' text now displays completely in
red.
This bug appears again in M18.  Same symptoms as before -- the first letter of 
"Integer" has a different color from the rest on both the Mac and Windows 
apprunner builds.

Marking as "css1" because this is incorrect CSS1 rendering behavior.
Status: VERIFIED → REOPENED
Keywords: css1, nsbeta3
Resolution: FIXED → ---
Target Milestone: M8 → M18
Possibly due to the nsTextTransformer whitespace problem - I'll check it out.
Assignee: buster → attinasi
Status: REOPENED → NEW
The same problem that kip fixed a year ago has re-appeared (like before, style 
is fine). 

Over to buster to look into, with a newer, slimmer and more economical testcase 
(to be attached).
Assignee: attinasi → buster
Component: Style System → Layout
Summary: Incorrect style inheritance → Incorrect rendering when font-variant is specified inside of element with text-decoration
NOTE: this bug is exhibited in PR2 as well.

Taking off of the beta3 radar: if resources free up we may re-evaluate this one 
for beta3.
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future
QA Contact: chrisd → py8ieh=bugzilla
Summary: Incorrect rendering when font-variant is specified inside of element with text-decoration → Incorrect rendering when font-variant is specified inside of element with text-decoration [FONT]
Upon managerial request, adding the "testcase" keyword to 84 open layout bugs that
do not have the "testcase" keyword and yet have an attachement with the word
"test" in the description field. Apologies for any mistakes.
Keywords: testcase
Nominating for 6.5.
Keywords: nsbeta3nsbeta1
Whiteboard: [nsbeta3-]
Build reassigning Buster's bugs to Marc.
Assignee: buster → attinasi
Blocks: 104166
Whiteboard: [CSS1-5.4.3][CSS1-5.2.4]
Dupping forward to a bug with a real assignee and complete analysis of the problem.

*** This bug has been marked as a duplicate of 181336 ***
Status: NEW → RESOLVED
Closed: 20 years ago17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.