If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No form helper zoom on tap of field input

VERIFIED FIXED in Firefox 6

Status

Fennec Graveyard
General
P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: aaronmt, Assigned: vingtetun)

Tracking

({regression})

Trunk
Firefox 6
ARM
Android
regression

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Build: Mozilla/5.0 (Android; Linux armv7l; rv:6.0a1) Gecko/20110517 Firefox/6.0a1 Fennec/6.0a1

Device: HTC Nexus One
Android: 2.3.4
Keyboard: Android Stock

Currently with the above build, on tap of any content input field there is no form assistant zoom to the particular field.

EX: Zoom (like 4.0.1) to the input field 
AR: No zoom

Tested on: 
* http://contacts.google.com
* http://ncix.com (search field)
* http://canadacomputers.com (search field)
(Reporter)

Updated

6 years ago
Priority: -- → P1
(Reporter)

Comment 1

6 years ago
Guessing bug Bug 656373

http://hg.mozilla.org/mozilla-central/rev/a6391aea48e5
(In reply to comment #1)
> Guessing bug Bug 656373
> 
> http://hg.mozilla.org/mozilla-central/rev/a6391aea48e5

Good guess I believe. :)
(In reply to comment #2)
> (In reply to comment #1)
> > Guessing bug Bug 656373
> > 
> > http://hg.mozilla.org/mozilla-central/rev/a6391aea48e5
> 
> Good guess I believe. :)

But it just landed. Did the patch actually get into the nightly build?
Assignee: nobody → 21
(Reporter)

Comment 4

6 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > Guessing bug Bug 656373
> > > 
> > > http://hg.mozilla.org/mozilla-central/rev/a6391aea48e5
> > 
> > Good guess I believe. :)
> 
> But it just landed. Did the patch actually get into the nightly build?

Yeah, http://hg.mozilla.org/mozilla-central/shortlog/69597
(Reporter)

Updated

6 years ago
Keywords: regressionwindow-wanted
Blocks: 656373
Created attachment 533305 [details] [diff] [review]
Patch

Maths was wrong :)

My concern with this patch is that it thought the desktop build is a tablet, do I have done another error with math? (the code reports 127 dpmm for deskop build)
Attachment #533305 - Flags: review?(mark.finkle)
(In reply to comment #5)
> My concern with this patch is that it thought the desktop build is a tablet,
> do I have done another error with math? (the code reports 127 dpmm for
> deskop build)

displayDPI is usually 96 on desktop platforms, and 480p / 96ppi * 25.4mm/inch = 127mm.

In bug 656973 (preference UI), we ended up using 124mozmm as the "tablet" threshold on Android, and 1024px as the "tablet" threshold on other platforms.  This is necessary because our chrome theme uses mozmm on Android and px on other platforms.  On non-Android platforms, it acts like the display is 240dpi when really it is 96dpi.  This throws off anything that wants to use mozmm or displayDPI for chrome elements on non-Android platforms.

For a long-term solution, we should use mozmm and real dpi by default on all platforms, and maybe provide an add-on for Fennec desktop that helps developers simulate different screen sizes and densities.
Created attachment 533313 [details] [diff] [review]
Patch v0.2

Well let's consider device with 96 dpi are not tablet.
Attachment #533305 - Attachment is obsolete: true
Attachment #533305 - Flags: review?(mark.finkle)
Attachment #533313 - Flags: review?(mark.finkle)
(In reply to comment #7)
> Well let's consider device with 96 dpi are not tablet.

How about "if (dpi <= 96) return (window.innerWidth > 1024);" so it works roughly the same as the preference UI.  And we can file a followup bug to fix this all to work more consistently on desktop.
Comment on attachment 533313 [details] [diff] [review]
Patch v0.2

Let's use Matt's tweak for now:

if (dpi <= 96)
  return (window.innerWidth > 1024);

r+ with that
Attachment #533313 - Flags: review?(mark.finkle) → review+
Duplicate of this bug: 657836
http://hg.mozilla.org/mozilla-central/rev/d9080dd8b3f2
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 658506
(Reporter)

Comment 13

6 years ago
Verified fixed
Build: Mozilla/5.0 (Android; Linux armv7l; rv:6.0a1) Gecko/20110520 Firefox/6.0a1 Fennec/6.0a1
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 6
You need to log in before you can comment on or make changes to this bug.