multiple plugin container processes aren't cleaned after closing tabs

RESOLVED DUPLICATE of bug 501485

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 501485
7 years ago
7 years ago

People

(Reporter: Andreas Richter, Unassigned)

Tracking

2.0 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

having opened videos in several tabs opens seperate plugin container child processes. after closing tabs, these child process still exist, taking up memory and slowing firefox/flash down.

Reproducible: Always

Steps to Reproduce:
1. open several flash videos in tabs
2. plugin container child process spawns
3. closing tabs doesnt clean up plugin container processes

Actual Results:  
plugin container processes remain

Expected Results:  
plugin container processes should be closed

Updated

7 years ago
Version: unspecified → 4.0 Branch
There should be only one plugin_container process for each plugin.
For example one for flash, one for silverlight ....

>1. open several flash videos in tabs
Please provide example URLs and your used plugin versions.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: 4.0 Branch → 2.0 Branch
(Reporter)

Comment 2

7 years ago
:( sry i should have checked the repeatability first.
But in the past i noticed in process hacker that at least 5+ plugin processes where opened when I was reading pdfs and watching videos (maybe in several firefox instances - dont know anymore). Or that problem existed in previous versions!??!

But cleaning up the process when tab is closed is repeatable. ie http://www.ros.org/workshops/eccv/2010/Vedaldi.pdf -> open in browser
-> close tab
-> check processes (ie via processhacker) -> plugin container child process remains
>maybe in several firefox instances
Firefox is always only one instance unless you have multiple profiles and use a special commandline option.

>But cleaning up the process when tab is closed is repeatable
That is a pdf and that is downloaded and starts foxitreader as helper application on my system -> You forgot to include the used plugin and version

Comment 4

7 years ago
The current behavior is intentional. The processes shouldn't be doing anything if there are no plugins on currently loaded pages., and so shouldn't have an affect on general performance at all.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501485
You need to log in before you can comment on or make changes to this bug.