Password Manager PopUp should show who (origin/webpage/FQDN) is requesting the master password

RESOLVED DUPLICATE of bug 432020

Status

()

enhancement
RESOLVED DUPLICATE of bug 432020
8 years ago
2 years ago

People

(Reporter: stefan, Unassigned)

Tracking

(Depends on 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

When using the password manager with a master password, while using a lot of open taps, its not always clear who (which page / FQDN) is actually requesting now the master password to retrieve my credentials from the password manager.

Enhancement: The popup should show who is requesting my credentials.

Reproducible: Always

Steps to Reproduce:
1. Use password manager
2.
3.
Version: unspecified → Trunk
Reporter, do you have new informations about this issue?
Posted image Screenthot
As you can see in the screenshot, my Password is required. But the page that is acutally in focus does not require the password. 

So, somethimes with a lot of tabs and probably iframes etc, it is very difficult to determine which page is actually requiring access to my password store.
Hence, it would be very helpful to see, which page it actually is, before I grant access?

-> the popup dialog should e.g. tell 

" The site www.google.com/ig is requesting access to your password store. Please enter master password "
Probably depends on bug 1271851.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Depends on: 1271851
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 432020
You need to log in before you can comment on or make changes to this bug.