Last Comment Bug 658001 - need to clear mouse capture if the capturing frame is inside a hidden deck panel or hidden tab
: need to clear mouse capture if the capturing frame is inside a hidden deck pa...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: Timothy Nikkel (:tnikkel)
:
Mentors:
Depends on: 698266
Blocks: 655263
  Show dependency treegraph
 
Reported: 2011-05-18 11:44 PDT by Timothy Nikkel (:tnikkel)
Modified: 2011-10-30 05:53 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.48 KB, patch)
2011-05-18 11:45 PDT, Timothy Nikkel (:tnikkel)
roc: review+
Details | Diff | Review
patch v2 (4.30 KB, patch)
2011-10-24 22:16 PDT, Timothy Nikkel (:tnikkel)
roc: review+
Details | Diff | Review

Description Timothy Nikkel (:tnikkel) 2011-05-18 11:44:09 PDT
When a view is hidden it clears the mouse capture if it is in that view. I think we'll need to keep this behaviour. Just dropping mouse capture based on the IsActive of the docshell/presshell I don't think is enough because we have other decks (namely Panorama uses a deck above the tabbrowsers to hide/show the Panorama view).
Comment 1 Timothy Nikkel (:tnikkel) 2011-05-18 11:45:32 PDT
Created attachment 533348 [details] [diff] [review]
patch
Comment 2 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-05-18 14:48:52 PDT
Comment on attachment 533348 [details] [diff] [review]
patch

Review of attachment 533348 [details] [diff] [review]:
-----------------------------------------------------------------

Can you also rewrite ClearMouseCapture(nsIView*) so that it uses ClearMouseCapture(nsIFrame*)? E.g. I think you should be able to find the nearest view with a frame, then call ClearMouseCapture on that frame.
Comment 3 Timothy Nikkel (:tnikkel) 2011-10-24 22:16:50 PDT
Created attachment 569281 [details] [diff] [review]
patch v2

Applied review comment.
Comment 4 Timothy Nikkel (:tnikkel) 2011-10-25 11:30:34 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/8c77d5a44c7c
Comment 5 Ed Morley [:emorley] 2011-10-25 18:01:23 PDT
https://hg.mozilla.org/mozilla-central/rev/8c77d5a44c7c

Note You need to log in before you can comment on or make changes to this bug.