Erroneous "This product/version has been updated in the database." message after unsuccessfully trying to set >4 Featured versions

VERIFIED INVALID

Status

VERIFIED INVALID
8 years ago
7 years ago

People

(Reporter: stephend, Assigned: lonnen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Steps to Reproduce:

1. Log in as an Admin, and load https://crash-stats-dev.allizom.org/admin/branch_data_sources
2. Set > 4 Featured versions of a given product

Actual Results:

Uh oh! Something went wrong...

"There are already 4 featured versions of this product. Set 1 of the featured products to not be featured, then try again.

This product/version has been updated in the database."

Expected Results:

Since the first message explains they weren't added, the second is erroneous.
(Assignee)

Comment 1

8 years ago
Camino -- warns that there are already 4 but sets a check indicating a 5th despite the warning, and gives confirmation of a chance in the database. After the 5th it just gives the warning but no additional versions are set as featured

Fennec -- no warnings at all and I'm at 8 checked so far

Firefox -- same as Camino

SeaMonkey -- warns at 4, does not set a 5th. Gives confirm of database despite warning.

Thunderbird -- same as Fennec, 8 so far and no warning
(Assignee)

Comment 2

8 years ago
Comment 1 has been filed as a separate error (bug 658163).

The issue reported here is technically not an error, because the database entry is always updated, even if it is just updated with the same information. If you open an entry and hit save without changing any field it will accurately say it was updated. When there are too many featured versions there is still an update, but the flag is changed to false automagically and that message is displayed.

Both messages are occasionally appropriate. For example: if you somehow have too many set already (config change), and try to modify one of the existing featured builds it will be flipped to unfeatured because you're over the limit and the entry would need to be updated.

A two part solution:

The first error message should be changed to be more helpful -- something like "You've already got 4 featured versions, so this one cannot also be featured. Please remove some featured versions to make room."

If none of the fields in the model have been changed from what is already in the DB it shouldn't send an update to the DB, and then it should indicate whether or not an update was made.

An alternative would be to change the interface. I could see providing x number of drop down lists for the user to choose from and having the user mark x number as 'featured' have x drop down lists to choose featured versions from.
(Assignee)

Comment 3

8 years ago
Comment 2 was accidentally submitted in the middle of editing. Ignore that last paragraph, please.(In reply to comment #2)

Comment 4

8 years ago
As a note, I see us potentially wanting to track 5 versions for Firefox right now (the latest 3.6, plus Nightly/7.0a1, Aurora/6.0a2, Beta/5.0, Release/4.0.1). But if it's 4 versions, that's better than 3 at least, as we at least can track all the normal channels.
(Assignee)

Updated

7 years ago
Depends on: 658163
(Assignee)

Comment 5

7 years ago
Please verify that this still exists following the resolution of 658163.
Status: NEW → ASSIGNED
(Reporter)

Comment 6

7 years ago
It appears it's regressed? http://screencast.com/t/CIYcuQwSn

Now, I get a 500 Internal Server Error trying to add a new Fennec version.
(Assignee)

Comment 7

7 years ago
Thanks Stephen. If you can give me 5 minutes tomorrow we should be able to resolve this.
(Assignee)

Comment 8

7 years ago
Following the resolution of 673183 this should be fixed as well. What say you, QA?
(Reporter)

Comment 9

7 years ago
Yeah, I tested adding, updating, deleting, featuring, for:

Thunderbird
SeaMonkey
Fennec
Firefox
Camino

all seem to work fine.
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 10

7 years ago
Verified.
Status: RESOLVED → VERIFIED
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.