dis() output can prematurely truncate with one-length atoms

RESOLVED DUPLICATE of bug 842419

Status

()

--
trivial
RESOLVED DUPLICATE of bug 842419
8 years ago
3 years ago

People

(Reporter: dvander, Assigned: dvander)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 533473 [details] [diff] [review]
patch

SrcNotes() in the shell can accidentally print a NUL character into the output buffer, because it passes the wrong buffer length into PutEscapedString. You get this:

Source notes:
 ofs  line    pc  delta desc     args
---- ---- ----- ------ -------- ------
  0:    2     0 [   0] newline 
  1:    3     0 [   0] label    atom 0 (
Attachment #533473 - Flags: review?
Attachment #533473 - Flags: review? → review?(jwalden+bmo)

Updated

8 years ago
Attachment #533473 - Flags: review?(jwalden+bmo) → review+
Code was removed in http://hg.mozilla.org/mozilla-central/rev/88c652c92bc8
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 842419
You need to log in before you can comment on or make changes to this bug.