Last Comment Bug 658167 - Swap mozilla-aurora to gcc 4.5 when m-c merges there on May 24th
: Swap mozilla-aurora to gcc 4.5 when m-c merges there on May 24th
Status: RESOLVED FIXED
[mozconfig] nominated by armen at com...
:
Product: Release Engineering
Classification: Other
Component: Other (show other bugs)
: other
: x86 Linux
: P3 normal (vote)
: ---
Assigned To: Armen Zambrano [:armenzg] - Engineering productivity
:
Mentors:
: 659630 (view as bug list)
Depends on:
Blocks: gcc4.5
  Show dependency treegraph
 
Reported: 2011-05-18 21:45 PDT by Nick Thomas [:nthomas]
Modified: 2013-12-27 14:34 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
affected


Attachments
[mozconfigs] merge from m-c to m-a (23.58 KB, patch)
2011-05-25 08:22 PDT, Armen Zambrano [:armenzg] - Engineering productivity
bhearsum: review+
Details | Diff | Splinter Review

Description Nick Thomas [:nthomas] 2011-05-18 21:45:42 PDT

    
Comment 1 Mike Hommey [:glandium] 2011-05-18 22:22:32 PDT
(and again when merged to beta, and again when merged to release ; really, bug 558180 would make life easier)
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-05-25 07:38:50 PDT
*** Bug 659630 has been marked as a duplicate of this bug. ***
Comment 3 Armen Zambrano [:armenzg] - Engineering productivity 2011-05-25 07:42:45 PDT
We forgot to track it for Firefox 6.
Comment 4 Armen Zambrano [:armenzg] - Engineering productivity 2011-05-25 08:22:57 PDT
Created attachment 535069 [details] [diff] [review]
[mozconfigs] merge from m-c to m-a

I did this:
* for each platform I cd into it and run this:
> rsync -r mozilla-central/* mozilla-aurora
* I added new files like this:
> for file in `hg st -un`; do hg add $file; done
* then I run this:
> for file in `find . -type f -name mozconfig | grep aurora`; do sed s/nightly/aurora/ < $file > $file.2; mv $file.2 $file; done

The last one fixes keeping the right update channel.
Comment 5 Ben Hearsum (:bhearsum) 2011-05-25 08:31:17 PDT
Comment on attachment 535069 [details] [diff] [review]
[mozconfigs] merge from m-c to m-a

r+ for the mozilla2/ portions. The thunderbird/ bits look fine to me too, but you should get review from either gozer or Standard8 for them anyways.
Comment 6 Armen Zambrano [:armenzg] - Engineering productivity 2011-05-25 09:46:08 PDT
Comment on attachment 535069 [details] [diff] [review]
[mozconfigs] merge from m-c to m-a

I landed the mozilla2/ part of it and left thunderbird out of it until reviews come in:
http://hg.mozilla.org/build/buildbot-configs/rev/3bcd07c94764
Comment 7 Mark Banner (:standard8) (afk until 26th July) 2011-05-25 11:11:35 PDT
Comment on attachment 535069 [details] [diff] [review]
[mozconfigs] merge from m-c to m-a

Thanks for thinking about Thunderbird. There's actually a couple of things I need to check before we do turn on/switch to that channel, so if you don't mind, I'll handle this change in a follow-up bug once I've got the confirmation.

Thanks again.
Comment 8 Armen Zambrano [:armenzg] - Engineering productivity 2011-05-25 11:27:06 PDT
standard8 all yours :)
Comment 9 Armen Zambrano [:armenzg] - Engineering productivity 2011-05-25 13:04:14 PDT
I have marked bug 558180 to deal with tracking updating the mozconfigs forward on the next merge day.

There is nothing left to be done on this bug.

I checked that the mozconfig looked right on the nightly build.
Can any of you verify it?
Comment 10 Nick Thomas [:nthomas] 2011-05-25 15:45:38 PDT
Mark, despite comment #8 the Thunderbird changes did land.
Comment 11 Mark Banner (:standard8) (afk until 26th July) 2011-05-26 01:50:16 PDT
(In reply to comment #10)
> Mark, despite comment #8 the Thunderbird changes did land.

Ok, thanks, we'll survive :-)
Comment 12 Armen Zambrano [:armenzg] - Engineering productivity 2011-05-26 07:01:09 PDT
(In reply to comment #10)
> Mark, despite comment #8 the Thunderbird changes did land.

Sorry :(
Comment 13 Armen Zambrano [:armenzg] - Engineering productivity 2011-05-26 14:09:27 PDT
asa what does the nomination imply?
That someone will check that Firefox 6 is compiled with gcc-4.5?
Comment 14 Virgil Dicu [:virgil] [QA] 2011-08-12 09:05:44 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101 Firefox/6.0

Can this issue be set to verified fixed? Has the initial bug been fixed?
Comment 15 Mike Hommey [:glandium] 2011-08-16 22:48:29 PDT
Unfortunately, the 6.0 builds off mozilla-release are not built with gcc 4.5 and PGO :(
Comment 16 Nick Thomas [:nthomas] 2011-08-17 00:40:32 PDT
(In reply to Mike Hommey [:glandium] from comment #15)
> Unfortunately, the 6.0 builds off mozilla-release are not built with gcc 4.5
> and PGO :(

That's strange, because we updated the mozconfigs in bug 676083. And it looks like we used them in the linux32 log:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/6.0-candidates/build1/logs/release-mozilla-release-linux_build-build1.txt.gz

about:buildconfig also says gcc 4.5.2. Where do you see the issue ?
Comment 17 Mike Hommey [:glandium] 2011-08-17 00:56:00 PDT
I saw the issue on http://tbpl.allizom.org/?tree=Mozilla-Release&usebuildbot=1
Comment 18 Mike Hommey [:glandium] 2011-08-17 00:56:30 PDT
(In reply to Mike Hommey [:glandium] from comment #17)
> I saw the issue on
> http://tbpl.allizom.org/?tree=Mozilla-Release&usebuildbot=1

(that is, the build logs from there, and the talos results which are seriously regressed)
Comment 19 Nick Thomas [:nthomas] 2011-08-17 00:59:31 PDT
Ah hah, that's because Rail only did the release/ dir, and not the others. Where do you want to fix that Rail ?
Comment 20 Nick Thomas [:nthomas] 2011-08-17 01:01:36 PDT
BTW, those are builds on tbpl are triggered by the landings in the repo, rather than the actual release bits. We should still fix the configs though.
Comment 21 Rail Aliiev [:rail] 2011-08-17 01:56:55 PDT
I filed bug 679638

Note You need to log in before you can comment on or make changes to this bug.