Last Comment Bug 658239 - Add a missing storeDouble implementation for ARM to fix TI build.
: Add a missing storeDouble implementation for ARM to fix TI build.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: ARM Linux
: -- blocker (vote)
: ---
Assigned To: Jacob Bramley [:jbramley]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-19 06:00 PDT by Jacob Bramley [:jbramley]
Modified: 2011-05-20 06:25 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add missing storeDouble/loadDouble implementations to the ARM back-end. (9.24 KB, patch)
2011-05-19 06:00 PDT, Jacob Bramley [:jbramley]
bhackett1024: review+
Details | Diff | Splinter Review

Description Jacob Bramley [:jbramley] 2011-05-19 06:00:42 PDT
Created attachment 533617 [details] [diff] [review]
Add missing storeDouble/loadDouble implementations to the ARM back-end.

The TI branch is burning again, because the ARM back end is missing an overloaded variant of storeDouble. The attached patch adds the missing functionality.

Note that because this branch already fails many tests on ARM, the implementation is basically untested, though the tricky bits were tested independently.

I also added a similar loadDouble variant. It isn't currently used, but it's present in the x86 back-end and it was trivial to add to ARM since storeDouble and loadDouble use the same back-end method.
Comment 1 Brian Hackett (:bhackett) 2011-05-19 07:15:26 PDT
Comment on attachment 533617 [details] [diff] [review]
Add missing storeDouble/loadDouble implementations to the ARM back-end.

Where/how are tests failing on ARM?  (Only the builds show up on tinderbox).
Comment 2 Jacob Bramley [:jbramley] 2011-05-20 02:40:11 PDT
(In reply to comment #1)
> Where/how are tests failing on ARM?  (Only the builds show up on tinderbox).

I saw around 40-50 failures a few days ago, but now I just see a
handful:

harmony-jacob-0:~/moz/jm.d$ jit-test --jitflags=j
/work/moz/jm/js/src/jit-test ~/moz/jm.d
python jit_test.py /home/jacbra01/moz/jm.d/js --jitflags=j
[1353|   4|1357] 100% ===============================================>|  126.2s
FAILURES:
    -j /work/moz/mozilla.org/projects/jaegermonkey/js/src/jit-test/tests/basic/arith.js
    -j /work/moz/mozilla.org/projects/jaegermonkey/js/src/jit-test/tests/basic/testRegExpTest.js
    -j /work/moz/mozilla.org/projects/jaegermonkey/js/src/jit-test/tests/basic/testShiftLeft.js
    -j /work/moz/mozilla.org/projects/jaegermonkey/js/src/jit-test/tests/sunspider/check-date-format-tofte.js
~/moz/jm.d

The date format test always fails in my time zone so there are only
three real failures there. Using other --jitflags gives various subsets
of the above, so I think the problem is caused only in -j.

Also, I get the following error in jsapi-tests (run through "make
check"):

...
make[2]: Entering directory `/work/moz/mozilla.org/projects/jaegermonkey/objdir-jm-mobile-nightly/js/src/jsapi-tests'
../../../dist/bin/run-mozilla.sh ../../../dist/bin/jsapi-tests
../../../dist/bin/jsapi-tests: 1: Syntax error: word unexpected (expecting ")")
Comment 3 Jacob Bramley [:jbramley] 2011-05-20 03:43:59 PDT
http://hg.mozilla.org/projects/jaegermonkey/rev/bdb2a82cfd16
Comment 4 Jacob Bramley [:jbramley] 2011-05-20 06:25:28 PDT
(In reply to comment #2)
> I saw around 40-50 failures a few days ago, but now I just see a
> handful:

The remaining failures exist on the tracemonkey repository too, so they aren't related to type inference.

Note You need to log in before you can comment on or make changes to this bug.