If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Beta branding doesn't appears on RTL

RESOLVED WORKSFORME

Status

Mozilla Localizations
ar / Arabic
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Andreea Pod, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fennec 5.0b2])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 533646 [details]
rtl branding1

Mozilla /5.0 (Android;Linux armv7l;rv:5.0) Gecko/20110517 Firefox/5.0 Fennec/5.0
Device: LG Optimus 2X (Android 2.2) 

Steps to reproduce:
1. install arabic plugin: http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-linux-l10n/
2. go to about:firstrun or go to preferences

Expected results:
The brand should be "Firefox Beta"

Actual results:
The brand is still Nightly see screenshots
(Reporter)

Updated

6 years ago
Whiteboard: [fennec 5.0b2]
(Reporter)

Comment 1

6 years ago
Created attachment 533649 [details]
rtl branding2
(Reporter)

Updated

6 years ago
Component: General → ar / Arabic
Product: Fennec → Mozilla Localizations
QA Contact: general → arabic.ar
Version: Trunk → unspecified
Firefox 5 (desktop and mobile) beta don't have nightlies. The build you are using is from mozilla-central (i.e. Firefox 6). Unfortunately, fennec 5 betas are not build on daily basis, but roughly once per week. 

You can the beta builds here:
http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/
where the latest fennec 5 beta is at:
http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/5.0b2-candidates/build1/linux-i686/

Note: it is strange that beta tab appear in the preferences panel in your screenshot. are you sure this is a central nightly (as in the link you specified) and not an aurora build?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

6 years ago
The build that I have installed is from here:
http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/5.0b2-candidates/build1/android-r7/multi/
and the plugin for Arabic language is from here:
http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-linux-l10n/

The application is Firefox Beta branded but when I switch to ar language it changes into Nightly as you can see in screenshots.

Note:
- from the arabic plugin I've installed only the language pack 
- the beta tab is present because I was using a beta build
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
That explained it. The branding is included in the langpack, and since the langpack is from mozilla-central, it lacks the beta branding strings. Just to make sure this is the cause, can you try applying any LTR locale langpack on the beta build you're using.

Aside from that, I am not sure where to get fennec 5 localized builds or langpacks. I'll ask in #mobile.
Please re-test using the following Arabic plugin:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/5.0b2-candidates/build1/linux-i686/xpi/ar.xpi

Comment 6

6 years ago
Isn't thet one for Desktop?

For mobile I guess this should work:

http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/5.0b2-candidates/build1/maemo5-gtk/ar/
(Reporter)

Comment 7

6 years ago
Anas's link doesn't work (the language pack fails to install) but I was able to install it from Ioana's link. 

The branding now is ok, "Firefox Beta".
(In reply to comment #7)
> Anas's link doesn't work (the language pack fails to install) but I was able
> to install it from Ioana's link. 
> 

Sorry about that. I give you the linux-686 langpack instead of the android's one (which was kindly provided by Ioana).

> The branding now is ok, "Firefox Beta".

Good. Re-marking as resolved.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.