Closed Bug 658276 Opened 9 years ago Closed 1 year ago

Notification for Geolocation is not dismissed after choosing option Share

Categories

(Firefox for Android Graveyard :: General, defect)

Firefox 5
ARM
Android
defect
Not set

Tracking

(fennec-)

RESOLVED WONTFIX
Tracking Status
fennec - ---

People

(Reporter: ioana.chiorean, Unassigned)

Details

(Whiteboard: [Fennec 5.0b2])

Device: Samsung Google Nexus S (Android 2.3)
Build: Mozilla /5.0 (Android;Linux armv7l;rv:5.0) Gecko/20110517 Firefox/5.0 Fennec/5.0 

Steps to reproduce:
1. go to http://mozqa.com/data/firefox/geolocation/wifi-watch.html
2. at the notification choose SHARE

Expected behavior:
- You will see a screen with some text at the top which has your raw geolocation information followed by a map with your location.

Actual behavior:
- the expected information is present but the notification is not dismissed (if pressed again -second time- the notification is dismissed)
Whiteboard: [Fennec 5.0b2]
It's dismissed but something is triggering the notification panel twice
I can't reproduce this on nightly: Mozilla/5.0 (Android; Linux armv71; rv:6.0a1) Gecko/20110523 Firefox/6.0a1 Fennec/6.0a1.  Also tried google maps, and i do not see the notification page anymore.

Can you try another page that uses the geo notification window?   Can determine if its a webpage issue.
it is reproducible on [Fennec 5.0] Mozilla/5.0 (Android; Linux armv71; rv:5.0) Gecko/20110523 Firefox/5.0 Fennec/5.0

Now there is a pop up for mozqa and the second for maps.google. Is this intended? Shouldn't it be only one?
tracking-fennec: --- → ?
Is this still an issue? It's an old bug and we should always give an update when nominating an old bug.
This issue occurs on maps.google.com.

There's a change in behavior for http://mozqa.com/data/firefox/geolocation/wifi-watch.html where the map is not showing (regression)
Assignee: nobody → doug.turner
tracking-fennec: ? → +
Assignee: doug.turner → nobody
(In reply to Naoki Hirata :nhirata from comment #5)
> This issue occurs on maps.google.com.
> 
> There's a change in behavior for
> http://mozqa.com/data/firefox/geolocation/wifi-watch.html where the map is
> not showing (regression)

I can't reproduce this in current trunk build on the Galaxy Nexus.
With http://mozqa.com/data/firefox/geolocation/wifi-watch.html indeed the map is not showing. Did you file a new bug for that?
Keywords: qawanted
Keywords: qawanted
Assigning to myself to retest.
QA Contact: nhirata.bugzilla
Keywords: qawanted
tracking-fennec: + → -
Closing all opened bug in a graveyard component
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.