Last Comment Bug 658294 - TI: Assertion failure: v.isNumber() || v.isBoolean(), at jsobj.cpp:6578
: TI: Assertion failure: v.isNumber() || v.isBoolean(), at jsobj.cpp:6578
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Linux
: -- critical (vote)
: ---
Assigned To: general
:
:
Mentors:
: 658293 (view as bug list)
Depends on:
Blocks: infer-regress langfuzz
  Show dependency treegraph
 
Reported: 2011-05-19 09:11 PDT by Christian Holler (:decoder)
Modified: 2013-01-14 08:19 PST (History)
4 users (show)
choller: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Christian Holler (:decoder) 2011-05-19 09:11:27 PDT
The following testcase asserts on TI revision 4dff743ec04d (run with -j -m -n -a), tested on 64 bit:

test();
function test()
{
  try {
    instances = []
    for (var i = 0; i != 2; ++i) 
    instances[i]=constructor
    var i = 0;
    var instance = instances[i];
    var name = instance.name;
    for (var j = 1; j != instances; ++j) 
    if (i != j && instance instanceof name[j].constructor) {}
  } catch(ex) {}
}
test();
Comment 1 Brian Hackett (:bhackett) 2011-05-19 15:34:04 PDT
*** Bug 658293 has been marked as a duplicate of this bug. ***
Comment 2 Brian Hackett (:bhackett) 2011-05-19 16:07:51 PDT
On some paths through stubs::GetElem and ic::GetElement/CallElement, we did not call typeMonitor before returning to update type information for the result of the access (grumble... x2).

http://hg.mozilla.org/projects/jaegermonkey/rev/3a894ab530ae
Comment 3 Christian Holler (:decoder) 2013-01-14 08:19:05 PST
A testcase for this bug was automatically identified at js/src/jit-test/tests/jaeger/bug658294.js.

Note You need to log in before you can comment on or make changes to this bug.