Last Comment Bug 658363 - MOVE DEFINES FOR DOUBLE CONSTANTS OUT OF XSLT
: MOVE DEFINES FOR DOUBLE CONSTANTS OUT OF XSLT
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XSLT (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Trevor Saunders (:tbsaunde)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-19 12:51 PDT by Trevor Saunders (:tbsaunde)
Modified: 2011-06-03 16:17 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (15.46 KB, patch)
2011-05-19 12:59 PDT, Trevor Saunders (:tbsaunde)
jonas: review+
Details | Diff | Splinter Review
Fix probable typo (1022 bytes, patch)
2011-05-30 13:56 PDT, Landry Breuil (:gaston)
jonas: review+
Details | Diff | Splinter Review

Description Trevor Saunders (:tbsaunde) 2011-05-19 12:51:47 PDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110518 Firefox/6.0a1
Build Identifier: 

XSLT has some defines for doubles that would be useful outside of xslt

Reproducible: Always
Comment 1 Trevor Saunders (:tbsaunde) 2011-05-19 12:59:02 PDT
Created attachment 533763 [details] [diff] [review]
patch

first shot, there's a lot more random basic runtimey code in xslt/src/base that should go away eventually, but this atleast makes it smaller.
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-05-19 18:26:00 PDT
Comment on attachment 533763 [details] [diff] [review]
patch

Looks good to me!
Comment 3 Trevor Saunders (:tbsaunde) 2011-05-27 02:13:12 PDT
landed on mozilla-central hg.mozilla.org/mozilla-central/rev/2b53d3079c78
/TMP/LINK
Comment 4 Landry Breuil (:gaston) 2011-05-30 13:52:04 PDT
Fwiw, it looks there's a typo in the commit, line 56 of txDouble.cpp there's still a 'txdpun' type used, and this broke builds on at least OpenBSD/sparc64, as can be seen on http://buildbot.rhaalovely.net/builders/comm-central-sparc64/builds/25/steps/build/logs/stdio

/var/buildslave/comm-central-sparc64/build/mozilla/content/xslt/src/base/txDouble.cpp:56: error: 'txdpun' does not name a type
/var/buildslave/comm-central-sparc64/build/mozilla/content/xslt/src/base/txDouble.cpp:56: error: extra ';'

I guess s/txdpun/dpun/ fixes it, will test. Reopening in the meantime.
Comment 5 Landry Breuil (:gaston) 2011-05-30 13:56:07 PDT
Created attachment 536163 [details] [diff] [review]
Fix probable typo

Here's the hg patch i'm testing
Comment 6 Trevor Saunders (:tbsaunde) 2011-05-30 14:37:27 PDT
(In reply to comment #5)
> Created attachment 536163 [details] [diff] [review] [review]
> Fix probable typo
> 
> Here's the hg patch i'm testing

yeah, looks like  I missed a spot when I grepped for uses, sorry about that.
Comment 7 Landry Breuil (:gaston) 2011-05-31 00:04:36 PDT
The patch fixes the build for me. (well, make package still chokes with bus error on sparc64, but that's another story)
Comment 8 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-06-01 10:35:50 PDT
Comment on attachment 536163 [details] [diff] [review]
Fix probable typo

Thanks!
Comment 9 Trevor Saunders (:tbsaunde) 2011-06-01 14:28:59 PDT
LANDED http://hg.mozilla.org/mozilla-central/rev/61e6c962123c

Note You need to log in before you can comment on or make changes to this bug.