Last Comment Bug 658494 - Build warnings for out-of-order init list in nsAccTreeWalker.cpp
: Build warnings for out-of-order init list in nsAccTreeWalker.cpp
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla6
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
Depends on:
Blocks: cleana11y 646369
  Show dependency treegraph
 
Reported: 2011-05-20 03:08 PDT by Daniel Holbert [:dholbert]
Modified: 2011-05-20 07:04 PDT (History)
2 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
trivial fix (1.12 KB, patch)
2011-05-20 03:11 PDT, Daniel Holbert [:dholbert]
mzehe: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-05-20 03:08:23 PDT
Filing bug on this build warning:
{
/mozilla/accessible/src/base/nsAccTreeWalker.h:99:14: warning: ‘nsAccTreeWalker::mState’ will be initialized after
/mozilla/accessible/src/base/nsAccTreeWalker.h:98:8: warning:   ‘bool nsAccTreeWalker::mWalkCache’
/mozilla/accessible/src/base/nsAccTreeWalker.cpp:67:1: warning:   when initialized here
}
Comment 1 Daniel Holbert [:dholbert] 2011-05-20 03:11:31 PDT
Created attachment 533921 [details] [diff] [review]
trivial fix

This patch flips mWalkCache and mState in the init list, to match the ordering in the header file:
> 98   bool mWalkCache;
> 99   WalkState* mState;
http://mxr.mozilla.org/mozilla-central/source/accessible/src/base/nsAccTreeWalker.h#98
Comment 2 Marco Zehe (:MarcoZ) on PTO until August 15 2011-05-20 03:26:53 PDT
Comment on attachment 533921 [details] [diff] [review]
trivial fix

Review of attachment 533921 [details] [diff] [review]:
-----------------------------------------------------------------

Taking over this review since davidb's AFK for today and Monday, and after talking to Dholbert on IRC. r=me, thanks!
Comment 3 Daniel Holbert [:dholbert] 2011-05-20 04:01:10 PDT
http://hg.mozilla.org/projects/cedar/rev/7bffd92f4825
Comment 4 Mounir Lamouri (:mounir) 2011-05-20 07:04:13 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/7bffd92f4825

Note You need to log in before you can comment on or make changes to this bug.