Closed Bug 658554 Opened 10 years ago Closed 10 years ago

Undoing a tab pointing to about:blank does nothing

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 7

People

(Reporter: vingtetun, Assigned: vingtetun)

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
Steps to reproduce:
 * open a new tab by tapping the bottom left "New Tab" button
 * dismiss the awesomescree
 * Close the tab by tapping the red cross arrow next to the tab thumbnail
 * Observe the tab in the "undo" box
 * once you have observed it enought, tap on it to re-open it

Actual result:
 * the "undo" tab dissapear and nothing else happen

Expected result:
 * There is 2 options, the first one is that we re-open about blank, but I think this doesn't make sense to do that since the new tab button is just below. So instead I think we should not move the about:blank tab to the "undo" box
Attachment #533994 - Flags: review?(wjohnston)
Attachment #533994 - Flags: review?(mark.finkle)
Comment on attachment 533994 [details] [diff] [review]
Patch

seems good to me
Attachment #533994 - Flags: review?(mark.finkle) → review+
Attachment #533994 - Flags: review?(wjohnston) → review+
http://hg.mozilla.org/mozilla-central/rev/ce19ede6e34e
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
VERIFIED FIXED on:

Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110525 Firefox/7.0a1 Fennec/7.0a1 

Device: HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 7
bugspam
Assignee: nobody → 21
You need to log in before you can comment on or make changes to this bug.