Last Comment Bug 658704 - widget/src/gtk2 should use new pref utilities
: widget/src/gtk2 should use new pref utilities
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla7
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
:
Mentors:
Depends on: 656826
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-20 16:52 PDT by Masayuki Nakano [:masayuki] (Mozilla Japan)
Modified: 2011-08-31 07:55 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1.0 (22.31 KB, patch)
2011-05-20 16:52 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
no flags Details | Diff | Splinter Review
Patch v1.1 (22.31 KB, patch)
2011-05-26 06:05 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
roc: review+
Details | Diff | Splinter Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-05-20 16:52:06 PDT
Created attachment 534153 [details] [diff] [review]
Patch v1.0

Followup bug for bug 656826.

We should land this for Fx7 due to risk management.
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-05-26 06:05:01 PDT
Created attachment 535314 [details] [diff] [review]
Patch v1.1
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-05-26 17:07:06 PDT
Comment on attachment 535314 [details] [diff] [review]
Patch v1.1

Review of attachment 535314 [details] [diff] [review]:
-----------------------------------------------------------------

::: widget/src/gtk2/nsPSPrinters.cpp
@@ +127,5 @@
>              NS_LITERAL_CSTRING(NS_POSTSCRIPT_DRIVER_NAME "default"));
>  
> +    nsCAutoString list(PR_GetEnv("MOZILLA_POSTSCRIPT_PRINTER_LIST"));
> +    if (list.IsEmpty()) {
> +        Preferences::GetChar("print.printer_list", &list);

Use GetString with a direct return
Comment 3 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-05-27 01:18:44 PDT
http://hg.mozilla.org/mozilla-central/rev/4ea52c0bd5be
Comment 4 Vlad [QA] 2011-08-31 07:55:34 PDT
Hi guys. How can this be tested?
thanks

Note You need to log in before you can comment on or make changes to this bug.