Last Comment Bug 658725 - NS_EXTERNALSHARINGAPPSERVICE_CID value is wrong and fail to compile
: NS_EXTERNALSHARINGAPPSERVICE_CID value is wrong and fail to compile
Status: VERIFIED FIXED
:
Product: Core Graveyard
Classification: Graveyard
Component: File Handling (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla7
Assigned To: Oleg Romashin (:romaxa)
:
Mentors:
: 658955 (view as bug list)
Depends on:
Blocks: 582621
  Show dependency treegraph
 
Reported: 2011-05-20 18:07 PDT by Oleg Romashin (:romaxa)
Modified: 2016-06-22 12:16 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Compile fix (665 bytes, patch)
2011-05-20 18:07 PDT, Oleg Romashin (:romaxa)
doug.turner: review+
Details | Diff | Splinter Review

Description Oleg Romashin (:romaxa) 2011-05-20 18:07:16 PDT
Created attachment 534177 [details] [diff] [review]
Compile fix

http://hg.mozilla.org/mozilla-central/rev/5176c8f2691e#l6.50
    6.48 +#define NS_EXTERNALSHARINGAPPSERVICE_CID \
    6.49 +  {0xea782c90, 0xc6ec, 0x11df, \
    6.50 +  {0xbd3, 0x08, 0x00, 0x20, 0x0c, 0x9a, 0x66, 0x74}}
                ^ - this is wrong
Comment 1 Doug Turner (:dougt) 2011-05-22 17:16:49 PDT
How did this ever work?  when I reviewed Tero's patch, i assumed that it had basic testing.
Comment 2 Doug Turner (:dougt) 2011-05-23 03:07:48 PDT
*** Bug 658955 has been marked as a duplicate of this bug. ***
Comment 3 Oleg Romashin (:romaxa) 2011-05-23 07:41:19 PDT
I guess it did work before somehow by ignoring wrong value with compile warning...
Comment 4 Boris Zbarsky [:bz] 2011-05-23 13:44:06 PDT
Can you _please_ add metadata to things you want others to push for you?  :(
Comment 5 Doug Turner (:dougt) 2011-05-23 15:36:40 PDT
good idea.  might start requiring that on patches.  also, bzimport looks like it barfed on this patch:

hg qimport bz://658725

and

hg out

changeset:   70002:8e53a8d44a83
tag:         658725
tag:         qtip
tag:         tip
user:        Oleg Romashin <romaxa>
date:        Fri May 20 18:07:00 2011 -0700
summary:     imported patch 658725
Comment 6 Boris Zbarsky [:bz] 2011-05-23 16:34:06 PDT
Fwiw, I did push this to cedar: http://hg.mozilla.org/projects/cedar/rev/10bfe807438c

But yes, patches with no commit info from someone who should know better should just get r-.
Comment 7 Matt Brubeck (:mbrubeck) 2011-05-24 15:03:56 PDT
http://hg.mozilla.org/mozilla-central/rev/10bfe807438c
Comment 8 Mihaela Velimiroviciu (:mihaelav) 2011-08-23 06:38:35 PDT
Can anyone please provide some guidelines that I can use to verify this fix? Do I need to create any specific environment to test it?

Thanks!
Comment 9 Mihaela Velimiroviciu (:mihaelav) 2011-08-23 07:07:29 PDT
Verified the file uriloader/exthandler/unix/nsExternalSharingAppService.h in mozilla-central and changes mentioned in comment 7 are submitted. 

Changing resolution to VERIFIED-FIXED

Note You need to log in before you can comment on or make changes to this bug.