Closed Bug 658751 Opened 10 years ago Closed 10 years ago

Integrate FF with Mac OS X Lion's new Fullscreen features

Categories

(Firefox :: General, enhancement)

x86_64
macOS
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 639705

People

(Reporter: johandouma, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:5.0a2) Gecko/20110520 Firefox/5.0a2
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:5.0a2) Gecko/20110520 Firefox/5.0a2

From the Apple Website: 
"Full Screen Apps: Provide an immersive, focused user experience with a full screen app. NSApplication, NSWindow, and the NSWindowDelegate Protocol in Mac OS X Lion make it easy for you to create and manage full-screen user interfaces while providing you the power to design rich user interactions"

It doesn't say much but it basically means that full screen applications become stand alone screens, a lot more like spaces. Switching between apps in full screen mode can be done using Apple+Tab as well as through gestures on a trackpad; as usual, that hasn't really changed.

It's hard to see how this is useful unless it's actually used on a ma with Lion, but I can see this becoming a pretty important feature on macs. 

Reproducible: Always
Most Apple Apps in Lion already have the fullscreen button the top right hand corner. See screenshot attached.
Hardware: x86 → x86_64
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 639705
You need to log in before you can comment on or make changes to this bug.