Closed Bug 658806 Opened 9 years ago Closed 9 years ago

About:memory shows negative number after running V8 Benchmark

Categories

(Core :: JavaScript Engine, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 655642

People

(Reporter: guijoselito, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110521 Firefox/6.0a1
Build Identifier: 

After running v8 I went check about:memory. The "heap" was greater than "mapped", and "other" was negative.

Mapped Memory
532,725,760 B (100.0%) -- mapped
├──541,064,480 B (101.57%) -- heap
│  ├──490,391,344 B (92.05%) -- used
│  └───50,673,136 B (09.51%) -- unused
├────7,987,200 B (01.50%) -- js
│    ├──7,593,984 B (01.43%) -- mjit-code
│    └────393,216 B (00.07%) -- tjit-code
└──-16,325,920 B (-3.06%) -- other

Other Measurements
502,194,176 B -- resident
504,909,824 B -- heap-committed
  3,842,048 B -- heap-dirty
          0 B -- gfx-d2d-surfacecache
          0 B -- gfx-d2d-surfacevram
          0 B -- canvas-2d-pixel-bytes

I'm filling this bug, because I remembered reading http://blog.mozilla.com/nnethercote/2011/05/12/a-better-aboutmemory-stage-1-5/ 

Reproducible: Always
Thanks for the report!  I'm pretty sure this is a duplicate of bug 655642.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 655642
You need to log in before you can comment on or make changes to this bug.