Last Comment Bug 658834 - nsTextFrameThebes.cpp:1148:19: warning: unused variable ‘sc’
: nsTextFrameThebes.cpp:1148:19: warning: unused variable ‘sc’
Status: VERIFIED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Daniel Holbert [:dholbert]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-21 18:45 PDT by Daniel Holbert [:dholbert]
Modified: 2011-07-29 05:45 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix: remove unused variable (703 bytes, patch)
2011-05-21 18:49 PDT, Daniel Holbert [:dholbert]
jfkthame: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-05-21 18:45:30 PDT
Filing bug on this warning:
> nsTextFrameThebes.cpp: In function ‘void BuildTextRuns([...])’:
> nsTextFrameThebes.cpp:1148:19: warning: unused variable ‘sc’

Variable was introduced in...
http://hg.mozilla.org/mozilla-central/diff/3fd770ef6a65/layout/generic/nsTextFrameThebes.cpp#l1.31
...(bug 253317) without any usages.  Looks like it was just left over from an earlier version of the patch that needed it.
Comment 1 Daniel Holbert [:dholbert] 2011-05-21 18:49:03 PDT
Created attachment 534264 [details] [diff] [review]
fix: remove unused variable
Comment 2 Jonathan Kew (:jfkthame) 2011-05-22 01:47:16 PDT
Comment on attachment 534264 [details] [diff] [review]
fix: remove unused variable

Yup, looks like a leftover - thanks for cleaning up!
Comment 3 Daniel Holbert [:dholbert] 2011-05-22 09:59:13 PDT
http://hg.mozilla.org/projects/cedar/rev/dd111452d161
Comment 4 Matt Brubeck (:mbrubeck) 2011-05-23 08:48:02 PDT
http://hg.mozilla.org/mozilla-central/rev/dd111452d161
Comment 5 Simona B [:simonab ] 2011-07-29 05:45:53 PDT
Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110728 Firefox/8.0a1

Looked at: http://hg.mozilla.org/mozilla-central/file/f5f1e3822540/layout/generic/nsTextFrameThebes.cpp#l1187
Based on this I am marking this: VERIFIED FIXED.

Note You need to log in before you can comment on or make changes to this bug.