Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 658904 - Remove nsIDOMDocumentStyle
: Remove nsIDOMDocumentStyle
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM: CSS Object Model (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla7
Assigned To: :Ms2ger (⌚ UTC+1/+2)
Depends on: 667021
  Show dependency treegraph
Reported: 2011-05-22 14:13 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-08-24 01:51 PDT (History)
4 users (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

Patch v1 (24.57 KB, patch)
2011-05-22 14:13 PDT, :Ms2ger (⌚ UTC+1/+2)
roc: review+
jst: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-05-22 14:13:09 PDT
Created attachment 534321 [details] [diff] [review]
Patch v1
Comment 1 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-05-22 15:20:17 PDT
Comment on attachment 534321 [details] [diff] [review]
Patch v1

Review of attachment 534321 [details] [diff] [review]:

I am not a content peer so this needs additional review from someone who is.

::: dom/interfaces/core/nsIDOMDocument.idl
@@ +217,1 @@
>  };

nsIDOMDocument needs an IID rev.
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2011-05-23 00:34:45 PDT
Yes, will do (and its subclasses as well).
Comment 3 Johnny Stenback (:jst, 2011-05-25 17:08:06 PDT
Comment on attachment 534321 [details] [diff] [review]
Patch v1

r=jst, but yeah, rev the IID for nsIDOMDocument, and also for other interfaces that directly or indirectly inherit nsIDOMDocument (nsIDOMHTMLDocument, nsIDOMXMLDocument, and nsIDOMSVGDocument), just because they tend to be interfaces that are very commonly used by binary extensions etc.
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2011-05-26 05:07:04 PDT
Comment 5 Tom Hindle 2011-08-19 10:54:03 PDT
The actual file nsIDOMDocumentCSS.idl doesn't seem to have been deleted?
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2011-08-19 12:20:41 PDT
Indeed. I'll remove it when I next need to push.
Comment 7 :Ms2ger (⌚ UTC+1/+2) 2011-08-20 01:13:12 PDT
Or actually, Ed is going to in bug 667021.
Comment 8 Tom Hindle 2011-08-20 03:52:01 PDT
Thanks - I wasn't nit-picking, I have a idl -> C# compiler which couldn't compile that file.
Comment 9 Trif Andrei-Alin[:AlinT] 2011-08-24 01:51:47 PDT
It seems to have been removed after seeing the bug in comment 7.
Setting resolution to VERIFIED FIXED.

Note You need to log in before you can comment on or make changes to this bug.