Can't unsubscribe from feed, and deleting folder doesn't automatically unsubscribe as it should

RESOLVED FIXED

Status

MailNews Core
Feed Reader
--
major
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: jwatt, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

Some of my feeds just got jammed for some unknown reason. Selecting them in the Feed Subscriptions window did not enable the Remove button, preventing me from unsubscribe from them (with the intention of then resubscribing). Next I tried deleting them, then deleting them from the Trash. Astonishingly fully deleting the feed folders has not unsubscribed me from the feeds, since if I try to subscribe to these feeds I get told I already have a subscription! So it seems like Thunderbird has completely screwed me and has no workarounds to get these feeds back.
Jwatt did you try deleting the folders in the profile ?
Component: General → Feed Reader
Product: Thunderbird → MailNews Core
QA Contact: general → feed.reader

Comment 2

7 years ago
(this isn't dataloss afaict)

I don't claim to know the collection of RSS bugs, but perhaps your issue is in this list https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=substring&list_id=331409&field0-0-0=short_desc&bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&type0-0-1=substring&field0-0-1=keywords&type1-0-1=allwordssubstr&resolution=---&classification=Client%20Software&classification=Components&query_format=advanced&longdesc=unsubscrib%20subscrib&type0-0-0=anywordssubstr&component=Feed%20Reader&field1-0-0=short_desc&longdesc_type=allwordssubstr&product=MailNews%20Core&product=Thunderbird&field1-0-1=short_desc
Severity: critical → major
Status: NEW → UNCONFIRMED
Ever confirmed: false
Keywords: dataloss
Whiteboard: [dupeme]
Ludo: the folders no longer exist in the profile, so Thunderbird did delete them.

Wayne: I had directories full of archived and tagged blog posts, which for some reason got lost all their contents and got jammed preventing further blog posts from arriving in them, so it's certainly dataloss. Even if the bug that is preventing me from resubscribing to those feeds is fixed, I'll never get back those archived and tagged posts.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss
I guess the rdf file got corrupted. You still have the feed files from your profile are these are gone too ?

Updated

6 years ago
Duplicate of this bug: 653995

Comment 6

6 years ago
fixed by bug 711173/bug 705504.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.