Last Comment Bug 658999 - Shader compiles on Linux and OSX but not Windows
: Shader compiles on Linux and OSX but not Windows
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Benoit Jacob [:bjacob] (mostly away)
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-23 08:08 PDT by Bobby Richter [:secretrobotron]
Modified: 2012-01-16 06:20 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Bobby Richter [:secretrobotron] 2011-05-23 08:08:57 PDT
This demo works properly on several versions of OSX and Linux, but fails entirely on Windows: http://webmademovies.org/audio.3/

It looks like it doesn't like the core fragment shader which, unfortunately, is buried inside this massive file.

Will try to accompany with better examples soon.
Comment 1 Bobby Richter [:secretrobotron] 2011-05-23 08:09:44 PDT
cc'ing Dave Humphrey
Comment 2 Bobby Richter [:secretrobotron] 2011-05-23 10:33:15 PDT
This looks like it`s due to using ? conditionals in fragment shaders. I replaced them with if-else structures, and it works fine.

I also had to pull a couple of variable declarations out of loops.
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2011-05-25 12:08:37 PDT
If it's another D3DCompile() problem, like bug 658826, then there's not much we'll be able to do about it.

Maybe just forward this to the ANGLE issue tracker once you have a good testcase, so they can decide whether it's a ANGLE or D3DCompiler bug.
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2012-01-15 20:03:03 PST
Is that bug still reproducible? That would be a ANGLE or D3DCompiler bug, then.
Comment 5 Bobby Richter [:secretrobotron] 2012-01-16 05:42:14 PST
Coincidentally, I tried this out recently and it didn't work.

Let me try again with latest nightly. My machine is Win7 32-bit.
Comment 6 Bobby Richter [:secretrobotron] 2012-01-16 06:20:19 PST
Looks like this is no longer a problem. Old shader + old browser caused the problem.

Note You need to log in before you can comment on or make changes to this bug.