Closed Bug 659156 Opened 10 years ago Closed 9 years ago

Get new user id number from ldap when in ldap auth library

Categories

(Cloud Services :: Server: Core, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: telliott, Assigned: petef)

References

Details

php ldap library couldn't do compound statements, making doing an autoincrement in ldap impossible (and leaving us with a weird ldapsql combined library). We can do this in python, and can remove the sql dependency from here.
Blocks: 659132
Duplicate of this bug: 622680
New user module in server-core does the right ldap magic.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Reopening this and assigning it to Pete. In the sql -> ldap transition, we need to make sure the starting value in ldap is higher than the high value in sql.
Assignee: nobody → petef
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Blocks: 676423
cn=maxuid,ou=users,dc=mozilla created in all environments.

dn: cn=maxuid,ou=users,dc=mozilla
cn: maxuid
uidNumber: 1
objectClass: uidNext

stage: wiped db, started at uidNumber=1
prod: current max(user_ids.id) is 4141518, set uidNumber=5000000
dev: current max(user_ids.id) is 349902, set uidNumber=700000
test: current max(user_ids.id) is 27665, set uidNumber=100000
Status: REOPENED → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.